Bug 1517715 - Plan creation/update excludes required files
Summary: Plan creation/update excludes required files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 12.0 (Pike)
Hardware: All
OS: Linux
urgent
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: RHOS Maint
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-27 10:05 UTC by Jiri Tomasek
Modified: 2018-06-27 13:40 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-ui-8.3.1-0.20180303225336.57e3d96.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:39:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1734676 None None None 2017-11-27 14:29:37 UTC
OpenStack gerrit 523100 None master: MERGED tripleo-ui: Change plan files whitelist when creating plan (Ie0cc450dcad2ec2cae7c15daffe362dfca255f6f) 2018-03-21 13:29:22 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:40:23 UTC

Description Jiri Tomasek 2017-11-27 10:05:30 UTC
Description of problem:
In case when plan is created/updatd via Director UI using 'Local Folder' option UI uploads only files with specific extensions. This causes such created deployment plans to fail deployment as files required for successful deployment are missing.

Steps to Reproduce:
1. Create a new deployment plan via Director UI by using 'Lodal Folder' option, providing files from /usr/share/openstack-tripleo-heat-templates
2. When plan is created, list files in apropriate swift container 'openstack container list <planName>' to check if docker/docker-puppet.py object exists.

Actual results:
docker/docker-puppet.py object does not exist


Expected results:
docker/docker-puppet.py object exists

Comment 1 Jiri Tomasek 2017-11-27 10:07:50 UTC
Workaround: using the alternative 'Tar Archive' option to create/update plan.

Comment 12 errata-xmlrpc 2018-06-27 13:39:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.