Bug 1517770 - online documents are not listed
Summary: online documents are not listed
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-documents (Show other bugs)
(Show other bugs)
Version: 7.5
Hardware: x86_64 Linux
high
high
Target Milestone: rc
: ---
Assignee: Debarshi Ray
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks: 1519876
TreeView+ depends on / blocked
 
Reported: 2017-11-27 12:23 UTC by Martin Krajnak
Modified: 2018-05-17 14:39 UTC (History)
4 users (show)

Fixed In Version: gnome-documents-3.22.2-8.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 13:08:48 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 13:09 UTC
GNOME Bugzilla 791518 None None None 2017-12-12 17:09 UTC
GNOME Bugzilla 791613 None None None 2017-12-14 13:22 UTC

Description Martin Krajnak 2017-11-27 12:23:23 UTC
Description of problem:
Documents from online services like Google and Microsoft are not available in gnome-documents. I double checked the login in control center and the documents via web browser.

Version-Release number of selected component (if applicable):
gnome-documents-3.22.2-5.el7.x86_64
gnome-online-miners-3.22.0-2.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.Login to online acc (Google/Microsoft)
2.Open Documents
3.Hit ctrl+F
4.Click on chevron
5.Choose Google/Microsoft category

Actual results:
List is empty

Expected results:
Documents should be in the list

Additional info:
nothing suspicious in the console log

Comment 3 Debarshi Ray 2017-12-06 16:34:43 UTC
This scratch build fixes some more issues arising out of the new gjs:
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14698927

However, it's still not completely fixed.

Comment 8 Debarshi Ray 2017-12-07 16:51:40 UTC
Here's a non-scratch build:
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14707298

Comment 12 Debarshi Ray 2017-12-13 17:43:32 UTC
This doesn't work anymore with newer gjs versions:
  str.replace ('blue', 'red', 'g')

We need:
  str.replace (/blue/g, "red");

See the Firefox-specific notes in:
https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/String/replace

Comment 13 Debarshi Ray 2017-12-14 15:20:53 UTC
I built gnome-documents-3.22.2-8.el7:
https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=632989

Comment 15 Martin Krajnak 2017-12-18 17:02:54 UTC
Work as expected with gnome-documents-3.22.2-8.el7, great work !

Comment 18 errata-xmlrpc 2018-04-10 13:08:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770


Note You need to log in before you can comment on or make changes to this bug.