Bug 151778 - documentation: add info about how to load modules before others
documentation: add info about how to load modules before others
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-22 05:10 EST by Patrick C. F. Ernzer
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 10:27:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2005-03-22 05:10:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
Please have a look at IT #69031 (all Red Hat has access), can we please reproduce this and add it to the documentation?

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Have the need to make anaconda load a module before others (so that a particular disc shows up as /dev/sda
2. go through available documentation
3. find nothing
  

Actual Results:  While technically possible, there is no documentation

Expected Results:  all anaconda options to be documented

Additional info:

[from Issue]
By the way, while searching for a solution for this, I also took a look at the source code of anaconda. It seems that there is an undocumented option which can be given to the kernel of the anaconda boot CD as an command line argument. driverload is the name of this option, and it causes the modules specified this way to be loaded before any other modules. E.g if I put in isolinux.cfg this kind of line:

append ks=cdrom:/ks.cfg initrd=initrd.img ramdisk_size=65536 driverload=mptscsih

I can then be sure that mptscsih driver gets loaded before any other drivers. I guess it would be nice it this is documented somewhere, e.g. in /usr/share/doc/anaconda-<version>/command-line.txt file of anaconda rpm.
Comment 1 Jeremy Katz 2005-03-22 10:27:03 EST
The driverload paramter is not documented because it's not a guaranteed
interface.  It was added to address a specific problem for one release and we
reserve the right to pull it in future releases for a more complete solution to
the problem.

Note You need to log in before you can comment on or make changes to this bug.