Bug 151787 - freeradius rebuild for new OpenSSL needed
freeradius rebuild for new OpenSSL needed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: freeradius (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks: FC4Blocker
  Show dependency treegraph
 
Reported: 2005-03-22 07:53 EST by Joe Orton
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-04 12:42:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2005-03-22 07:53:45 EST
freeradius needs to be rebuilt to pick up the new OpenSSL sonames.

I tried a naive bump'n'rebuild but it's failing with gcc 4.x due to some bad code:

gcc  -O2 -Wall -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -m32 -march=i386 -mtune=pentium4
 -fpic -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS -DOPENSSL_NO_KRB5   -Wall -D_GNU_
SOURCE -g -Wshadow -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings -Wst
rict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -W
-Wredundant-decls -Wundef  -I../include  -DHOSTINFO=\"\" -DRADIUSD_VERSION=\"1.0
.1\"   -c mainconfig.c
mainconfig.c:66: error: static declaration of 'auth_port' follows non-static dec
laration
../include/radiusd.h:280: error: previous declaration of 'auth_port' was here
mainconfig.c:873: warning: no previous prototype for 'proxy_new_listener'
gmake[4]: *** [mainconfig.o] Error 1
gmake[4]: Leaving directory `/usr/src/redhat/BUILD/freeradius-1.0.1/src/main'
Comment 1 Thomas Woerner 2005-04-04 12:42:51 EDT
Fixed in rawhide in rpm freeradius-1.0.2-1 or newer.

Note You need to log in before you can comment on or make changes to this bug.