Bug 151788 - add translations
add translations
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: desktop-backgrounds (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-03-22 08:11 EST by Matthias Clasen
Modified: 2013-03-13 00:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-27 15:38:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2005-03-22 08:11:47 EST
We need to incorporate the translations in the .xml file describing the
backgrounds when they are ready. Check with Leon for the details.
Comment 1 Leon Ho 2005-04-26 03:47:58 EDT
cc'ing Sarah, Localization services manager. Make sure she will receive the
notification for translators when those are ready to be translated in elvis.

For FC4, here are the schedule from http://fedora.redhat.com/participate/schedule/
27 April  	Translation deadline (data provided) test3 devel freeze
9  May 	test3, translation build freeze (builds completed)
Comment 2 John (J5) Palmieri 2005-04-26 18:02:08 EDT
I'm totaly sure what needs to be done here.  Where do I get the translations and
what is the syntax to add them?

I assume I need to edit the desktop-backgrounds-basic.xml file which contains
entries like the following:

<?xml version="1.0"?>
<!DOCTYPE wallpapers SYSTEM "gnome-wp-list.dtd">
<wallpapers>
  <wallpaper>
    <name>Blast of Red</name>
    <filename>/usr/share/backgrounds/images/tiny_blast_of_red.jpg</filename>
    <options>stretched</options>
    <shade_type>solid</shade_type>
    <pcolor>#FFFFFF</pcolor>
    <scolor>#000000</scolor>
  </wallpaper>
</wallpapers>

Where would I put the translations?  I will be around on IRC around 11pm or 12am
EST tonight to see if we can fix this for the deadline.
Comment 3 Leon Ho 2005-04-27 02:40:43 EDT
Hi John, you should extract the strings in xml to po file for translation using
intltool. You can get step by step instructions in
/usr/share/doc/intltool-0.31.2/README.

Matthias and I have setup a module in elvis server a while ago (i think it is
"redhat-backgrounds". You need to check out that, add in pot (template for po)
files and initialize po files for different languages into po/. 

When you did that, translators (both community and in-house) should able to see
the updates from translate module which linked to redhat-backgrounds/po/
directory and translate them.

Then you should cvs up again and then get the latest translation and rebuild the
package to include those translations.

Refers to module like system-config-network for more references on the layout
and po files.

Ping tagoh, or me on IRC if you need any further assistance. If we cannot catch
each other, ping any system-config- maintainers they should able to give you
some tips as well.
Comment 4 John (J5) Palmieri 2005-04-27 15:38:23 EDT
Turns out the translations were done and all that was needed to do is package it
and build it.  Built in dist-fc4-HEAD and moved to dist-fc4.

Note You need to log in before you can comment on or make changes to this bug.