Bug 1517904 - tests/bugs/core/multiplex-limit-issue-151.t fails sometimes in upstream master
Summary: tests/bugs/core/multiplex-limit-issue-151.t fails sometimes in upstream master
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1542615
TreeView+ depends on / blocked
 
Reported: 2017-11-27 16:43 UTC by Nithya Balachandran
Modified: 2018-03-15 11:22 UTC (History)
1 user (show)

Fixed In Version: glusterfs-4.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1542615 (view as bug list)
Environment:
Last Closed: 2018-03-15 11:22:12 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nithya Balachandran 2017-11-27 16:43:43 UTC
Description of problem:

https://build.gluster.org/job/regression-test-with-multiplex/543/consoleText


volume remove-brick commit: failed: use 'force' option as migration is in progress

not ok 20 , LINENUM:53
FAILED COMMAND: gluster --mode=script --wignore volume remove-brick patchy slave26.cloud.gluster.org:/d/backends/brick3 commit
ok 21, LINENUM:55


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Nithya Balachandran 2017-11-27 16:45:27 UTC
This is caused by a timing issue where the remove-brick commit is sent before the rebalance is complete. As the volume is empty and we don't care about the rebalance as part of this test, replace the remove-brick commit with remove-brick force.

Comment 2 Worker Ant 2017-11-27 16:52:47 UTC
REVIEW: https://review.gluster.org/18869 (tests: Spurious failure multiplex-limit-issue-151.t) posted (#1) for review on master by N Balachandran

Comment 3 Worker Ant 2017-11-27 18:18:29 UTC
COMMIT: https://review.gluster.org/18869 committed in master by \"N Balachandran\" <nbalacha@redhat.com> with a commit message- tests: Spurious failure multiplex-limit-issue-151.t

A timing issue caused the remove-brick commit to fail.
Replaced 'remove-brick commit' with 'remove-brick force'.

Change-Id: I69144b2f7be34095dbd3a7d182e0bf01b27fb0a4
BUG: 1517904
Signed-off-by: N Balachandran <nbalacha@redhat.com>

Comment 4 Shyamsundar 2018-03-15 11:22:12 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.0, please open a new bug report.

glusterfs-4.0.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000092.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.