Bug 1517906 - nrpe-3.2.0-6.el7.x86_64.rpm over-writes live nrpe.cfg
Summary: nrpe-3.2.0-6.el7.x86_64.rpm over-writes live nrpe.cfg
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nrpe
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Stephen John Smoogen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-27 16:46 UTC by Clovis_Sangrail
Modified: 2018-10-05 17:19 UTC (History)
9 users (show)

Fixed In Version: nrpe-3.2.1-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-05 17:19:26 UTC


Attachments (Terms of Use)

Description Clovis_Sangrail 2017-11-27 16:46:04 UTC
Description of problem:
AFter installing nrpe-3.2.0-6.el7.x86_64.rpm (among other packages) via "yum -y update", my live nrpe.cfg was over-written with the distribution version.

Version-Release number of selected component (if applicable):
nrpe-3.2.0-6.el7.x86_64.rpm

How reproducible:
I did not reproduce this. 

Steps to Reproduce:
1. n/a
2.
3.

Actual results:


Expected results:


Additional info:

$ uname -a
Linux portal2 3.10.0-514.21.1.el7.x86_64 #1 SMP Thu May 25 17:04:51 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
$ cat /etc/redhat-release 
CentOS Linux release 7.4.1708 (Core) 
$

     (from "yum -y update" output)

Updated:
  firefox.x86_64 0:52.5.0-1.el7.centos                                          
  nagios.x86_64 0:4.3.4-3.el7                                                   
  nagios-common.x86_64 0:4.3.4-3.el7                                            
  nagios-devel.x86_64 0:4.3.4-3.el7                                             
  nagios-plugins-nrpe.x86_64 0:3.2.0-6.el7                                      
  nrpe.x86_64 0:3.2.0-6.el7                                                     
  php.x86_64 0:5.4.16-43.el7_4                                                  
  php-cli.x86_64 0:5.4.16-43.el7_4                                              
  php-common.x86_64 0:5.4.16-43.el7_4                                           
  php-dba.x86_64 0:5.4.16-43.el7_4                                              
  php-devel.x86_64 0:5.4.16-43.el7_4                                            
  php-embedded.x86_64 0:5.4.16-43.el7_4                                         
  php-gd.x86_64 0:5.4.16-43.el7_4                                               
  php-mbstring.x86_64 0:5.4.16-43.el7_4                                         
  php-odbc.x86_64 0:5.4.16-43.el7_4                                             
  php-pdo.x86_64 0:5.4.16-43.el7_4                                              
  php-pgsql.x86_64 0:5.4.16-43.el7_4                                            
  php-process.x86_64 0:5.4.16-43.el7_4                                          
  php-soap.x86_64 0:5.4.16-43.el7_4                                             
  php-xml.x86_64 0:5.4.16-43.el7_4                                              
  pypolicyd-spf.noarch 0:1.3.2-5.el7                                            
  python-gobject.x86_64 0:3.22.0-1.el7_4.1                                      
  python-gobject-base.x86_64 0:3.22.0-1.el7_4.1                                 
  python-pyspf.noarch 0:2.0.11-5.el7                                            

Complete!

Comment 1 Stephen John Smoogen 2017-11-27 16:50:01 UTC
OK that is weird. The file is listed as 

%config(noreplace) %{_sysconfdir}/nagios/nrpe.cfg

so it should have left a nrpe.cfg.rpmorig or a nrpe.cfg.rpmsave 

Do you know the version you had before?

Comment 2 Clovis_Sangrail 2017-11-27 17:37:07 UTC
Hi, I think this shows the previous version of nrpe:

# yum history info nrpe
Loaded plugins: fastestmirror, langpacks
Transaction ID : 40
Begin time     : Mon Nov 27 09:22:19 2017

.  .  .  .  .  .

    Updated nagios-plugins-nrpe-3.1.1-1.el7.x86_64      @epel
    Update                      3.2.0-6.el7.x86_64      @epel
    Updated nrpe-3.1.1-1.el7.x86_64                     @epel
    Update       3.2.0-6.el7.x86_64                     @epel

.  .  .  .  .  .

#

I will attach the full output if you want. I included the plugins package above because I wonder if it might be the culprit. 

I did not see any nrpe.cfg.rpm* file. I do not think I ever have, though nagios updates do that. I manually copied the nrpe.cfg file that I discovered after the yum update into the file "nrpe.cfg_rpmnew2" before restoring my live nrpe.cfg from a backup. Here is "/etc/nagios" now:

# cd /etc/nagios
# ls -l
total 184
-rw-rw-r--. 1 root root   12988 Sep 19 21:12 cgi.cfg
drwxr-x---. 2 root nagios  4096 Sep 19 21:12 conf.d
drwxr-xr-x. 3 root root    4096 Aug 25 11:05 live
-rw-r--r--. 1 root root     888 Jul 28 15:09 my-nagios.pp
-rw-r--r--. 1 root root     329 Jul 28 15:09 my-nagios.te
-rw-rw-r--. 1 root root   45801 Oct 18 13:59 nagios.cfg
-rw-rw-r--. 1 root root   44662 Sep 19 21:12 nagios.cfg.rpmnew
-rw-r--r--. 1 root root   12414 Nov 27 09:46 nrpe.cfg
-rw-r--r--. 1 root root   10710 Jun 14 20:50 nrpe.cfg_original
-rw-r--r--. 1 root root   12806 Aug  4 16:05 nrpe.cfg_rpmnew2
drwxr-x---. 2 root nagios  4096 Nov 27 09:22 objects
drwxr-xr-x. 3 root root    4096 Oct 18 13:58 oldstuff
-rw-r-----. 1 root apache    27 Sep 19 21:12 passwd
drwxr-x---. 2 root nagios  4096 Nov 27 09:22 private
#

Comment 3 Stephen John Smoogen 2017-11-27 18:27:12 UTC
OK I am not able to replicate on my test systems yet. 


Aug 08 17:59:21 Updated: nrpe-3.1.1-1.el7.x86_64
Aug 08 18:00:35 Updated: nrpe-selinux-3.1.1-1.el7.x86_64
Nov 27 18:21:44 Updated: nrpe-3.2.0-6.el7.x86_64
Nov 27 18:21:44 Updated: nrpe-selinux-3.2.0-6.el7.x86_64

  Updating   : nagios-common-4.3.4-3.el7.x86_64                                                                                                                         4/26
  Updating   : nrpe-3.2.0-6.el7.x86_64                                                                                                                                  5/26
warning: /etc/nagios/nrpe.cfg created as /etc/nagios/nrpe.cfg.rpmnew

I will try a couple more boxes today and see if I can figure out what caused it on your system... At this point I am not thinking the problem is with the package since the file is listed as noreplace in both RPMs. My only guess is something fooled rpm into thinking the file was not edited which would be an rpm bug. However I will check a couple other things todya.

Comment 4 Clovis_Sangrail 2017-11-27 19:37:13 UTC
OK.

I still have to roll this out to other machines. I will save nrpe.cfg, see what happens and update here if I get any more occurrences.

Comment 5 Fedora Update System 2018-07-24 22:50:17 UTC
nrpe-3.2.1-6.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-957b082df2

Comment 6 Fedora Update System 2018-07-25 19:52:10 UTC
nrpe-3.2.1-6.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-957b082df2

Comment 7 Fedora Update System 2018-07-26 11:49:43 UTC
nrpe-3.2.1-6.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-957b082df2

Comment 8 Fedora Update System 2018-10-05 17:19:26 UTC
nrpe-3.2.1-6.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.