Bug 151799 - Where are the laus packages for v4?
Where are the laus packages for v4?
Status: CLOSED DUPLICATE of bug 113381
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: audit (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Grubb
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-22 10:16 EST by Lee Whatley
Modified: 2015-01-07 19:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-04 15:12:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Whatley 2005-03-22 10:16:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3) Gecko/20050104 Red Hat/1.4.3-3.0.7

Description of problem:
LAuS (Linux auditing subsystem) appears not to be included with RHEL v4.  The release notes do not mention anything about this package being removed or depreciated.  The only package I can find in v4 that even looks vaguely like it should have the functionality of LAuS is the "audit" package which contains only two files: auditd and auditctl.  It does not however contain any init scripts, aucat, augrep, or ANY documentation whatsoever.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RHEL v4 and register with RHN
2. Run "up2date -u laus"

  

Actual Results:  The package is not found

Expected Results:  The package should have been downloaded from RHN and installed.  Better yet, up2date should have exited stating that the package was already installed because it should have been installed by default.

Additional info:
Comment 1 Jason Vas Dias 2005-03-22 10:30:53 EST
The LAuS package is not shipped with RHEL-4, and is replaced by audit .
I'm moving this bug to audit .
Comment 2 Steve Grubb 2005-03-23 16:57:48 EST
The audit package is still under active development. What was shipped is a
placeholder. Audit requires changes to the kernel to work properly. Both a new
kernel and a working audit will be released at some point in the future.

Hope this helps.
Comment 3 Lee Whatley 2005-03-23 17:21:25 EST
Well that doesn't really "help" me per se, but I appreciate the information.
Will the updated audit package be available on RHN as soon as it's ready, or
will it be deferred until RHEL v4 U1 comes out? Thanks!
Comment 4 Steve Grubb 2005-03-29 17:27:49 EST
I'm not sure when it will be available. The user space piece depends on having
some kernel code in place. The user space piece is available in rawhide (still
being developed, though), but does little good without the matching kernel.

I'll update this Bug Report when I have more information.
Comment 5 Steve Grubb 2005-08-04 15:12:42 EDT
This problem report is a duplicate of 113381. An errata is being prepared for a
package release on the next update. Thanks for reporting it.

*** This bug has been marked as a duplicate of 113381 ***
Comment 6 John 2008-05-19 08:29:26 EDT
My organization recently purchased RHEL 4 WS 64Bit late last year and I can 
not find the LaUS RPM, should I expect to find a LAuS RPM and if so can anyone 
tell me what the name of the RPM is, is there a laus in it somewhere?

Note You need to log in before you can comment on or make changes to this bug.