Bug 151820 - krb5-auth-dialog-0.2-3.i386.rpm refuses to install
Summary: krb5-auth-dialog-0.2-3.i386.rpm refuses to install
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: krb5-auth-dialog   
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords: EasyFix
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-22 16:59 UTC by Roozbeh Pournader
Modified: 2013-03-06 03:43 UTC (History)
1 user (show)

Fixed In Version: 0.2-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 18:48:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Roozbeh Pournader 2005-03-22 16:59:46 UTC
Description of problem:
krb5-auth-dialog-0.2-3.i386.rpm has a wrong requirement of:
   "krb5 >= ${krb5_version}"
which makes it refuse to install.

Version-Release number of selected component (if applicable):
krb5-auth-dialog-0.2-3

How reproducible:
Always

Steps to Reproduce:
1. rpm -Uvh krb5-auth-dialog-0.2-3.i386.rpm
  
Actual results:
It fails with the following error:

error: Failed dependencies:
        krb5 >= ${krb5_version} is needed by krb5-auth-dialog-0.2-3.i386


Expected results:
It should install

Comment 1 Roozbeh Pournader 2005-03-22 17:37:21 UTC
The bug is probably in using $ instead of % in the spec file, but I still can't
make it work because I can't find which package is actually providing "krb5".

Comment 2 Nalin Dahyabhai 2005-03-22 17:51:59 UTC
The requirement should be on 'krb5-libs', not 'krb5', should be fixed in 0.2-5.

Comment 3 David Zeuthen 2005-03-22 18:48:01 UTC
Nalin, thanks for fixing this. Closing as RAWHIDE.


Note You need to log in before you can comment on or make changes to this bug.