Bug 1518208 - gluster-devel ML subscription is broken
Summary: gluster-devel ML subscription is broken
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-28 12:18 UTC by sumantro
Modified: 2018-07-27 11:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-27 11:49:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)
err ss (97.82 KB, image/png)
2017-11-28 12:18 UTC, sumantro
no flags Details
with https (72.73 KB, image/png)
2017-11-28 12:27 UTC, sumantro
no flags Details

Description sumantro 2017-11-28 12:18:48 UTC
Created attachment 1359831 [details]
err ss

Description of problem:
The gluster-devel subscription is broken 

Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1.Load http://lists.gluster.org/mailman/listinfo/gluster-devel
2.Enter email,name and pass click Subscribe 


Actual results:
You will end up with site not found

Expected results:
should get subscribed or throw me an error

Additional info:

Comment 1 Nigel Babu 2017-11-28 12:27:24 UTC
Can you try starting at https://lists.gluster.org/mailman/listinfo/gluster-devel

Comment 2 sumantro 2017-11-28 12:27:42 UTC
Created attachment 1359835 [details]
with https

Comment 3 M. Scherer 2017-11-28 12:32:00 UTC
It work for me. Can you give more details like the exact date time of the error so I can dig in the log more easily ?

Comment 4 sumantro 2017-11-28 12:37:03 UTC
(In reply to M. Scherer from comment #3)
> It work for me. Can you give more details like the exact date time of the
> error so I can dig in the log more easily ?

2017-11-28 17-56-42

Comment 5 M. Scherer 2017-11-28 12:39:45 UTC
seems to be the blacklist of barracuda we did set up for spam prevention. I see 2 IP geolocated india in the log. 1 in Mumbai, 1 for a mobile phone provider.

Comment 6 sumantro 2017-11-28 12:51:01 UTC
(In reply to M. Scherer from comment #5)
> seems to be the blacklist of barracuda we did set up for spam prevention. I
> see 2 IP geolocated india in the log. 1 in Mumbai, 1 for a mobile phone
> provider.

It didnt throw me any error and I was registering with ping2sumantro@gmail.com which is a perfectly okay email address.

Comment 7 M. Scherer 2017-11-28 14:04:42 UTC
Yeah, I think we should work on the error message bit. 

My hope was that it wouldn't show errors messages for regular users, just for botnet, but I suspect the massive nat done by ISP is not working well with that plan.

But yes, that's because the IP are in DNS blacklist for spam., no matter what email you used.

Comment 8 sumantro 2017-11-28 18:03:43 UTC
The network I was trying from is Red Hat Bangalore and Atin also got the same error when he tried.

Comment 9 M. Scherer 2017-11-28 18:59:43 UTC
Bad :/ 

Ok, so let's fix that by adding the email manually, and then, I will see with IT about that issues, and we will fix it more correctly, is that ok ?

What lists do you want to be subscribed with that email ?

Comment 10 sumantro 2017-11-28 19:01:19 UTC
(In reply to M. Scherer from comment #9)
> Bad :/ 
> 
> Ok, so let's fix that by adding the email manually, and then, I will see
> with IT about that issues, and we will fix it more correctly, is that ok ?
> 
> What lists do you want to be subscribed with that email ?

gluster-devel

Comment 11 sumantro 2017-11-28 19:02:08 UTC
(In reply to M. Scherer from comment #9)
> Bad :/ 
> 
> Ok, so let's fix that by adding the email manually, and then, I will see
> with IT about that issues, and we will fix it more correctly, is that ok ?

Sounds good! :)
> 
> What lists do you want to be subscribed with that email ?

Comment 12 M. Scherer 2017-11-29 22:36:28 UTC
ok so I did subscribe the email you gave (using :

echo email@example.org |/usr/lib/mailman/bin/add_members -r - gluster-devel

I am going to see for the IP with IT

Comment 13 M. Scherer 2017-12-02 13:11:20 UTC
So today, we had another person coming on IRC with a blacklisted IP, this time broadband from Bezeqint, again on barracuda. I did disable barracuda for now to let the person subscribe.

Comment 14 M. Scherer 2018-07-27 11:49:23 UTC
Closing, since the faulty DNSBL got blocked.


Note You need to log in before you can comment on or make changes to this bug.