Bug 151825 - kernel-2.6.11-1.1191_FC4 : fail to make bootstrap in emacs CVS
Summary: kernel-2.6.11-1.1191_FC4 : fail to make bootstrap in emacs CVS
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-22 17:28 UTC by sangu
Modified: 2015-01-04 22:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 05:18:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sangu 2005-03-22 17:28:49 UTC
Description of problem:
emacs/src]$./temacs --batch --load loadup bootstrap
[...]
**************************************************
Warning: Your system has a gap between BSS and the
heap (11873316 byte).  This usually means that exec-shield
or something similar is in effect.  The dump may
fail because of this.  See the section about
exec-shield in etc/PROBLEMS for more information.
**************************************************

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1191_FC4

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
This problem doesn't happen in kernel-2.6.11-1.1185_FC4.

Comment 1 Justin Conover 2005-03-23 04:54:09 UTC
1191 bombs for me at this point:

SELinux: initialized (dev binfmt_misc), uses genfs_contexts
Kernel panic - not syncing: lib/kobject.c:143: spin_lock(lib/kobject.c:c03eb790)
already locked by lib/kobject.c/171. (Not tainted)

I have a dell prescion 420, another user has a problem booting up and a common
hardware peice we both have is a  "aic7xxx" scsi card.  Both the smp and regular.



Comment 2 sangu 2005-06-07 16:13:24 UTC
 * please see also : New dumping problem...
 http://lists.gnu.org/archive/html/emacs-devel/2005-03/msg01323.html

 $echo 0 >/proc/sys/kernel/randomize_va_space
 $setarch i386 make bootstrap

 bootstrap works well.

 * bug 101818



Comment 3 Dave Jones 2005-10-06 05:18:00 UTC
As mentioned here..
http://lists.gnu.org/archive/html/emacs-devel/2005-03/msg01504.html

This is an emacs bug.



Note You need to log in before you can comment on or make changes to this bug.