Bug 151846 - Revert USE_BROADCAST changes
Summary: Revert USE_BROADCAST changes
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ypbind   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Feist
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-22 20:54 UTC by Marty Wesley
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-20 00:55:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:355 normal SHIPPED_LIVE ypbind bug fix update 2005-05-19 04:00:00 UTC

Description Marty Wesley 2005-03-22 20:54:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
In a patch submitted by a customer and applied as is, USE_BROADCAST was set to 0.  It's normally set to 1 (from upstream) which makes ypbind do an RPC "ping" to all NIS servers at once and pick the first one that responds as the fastest.  If USE_BROADCAST is set to 0, ypbind will try each of the servers in /etc/yp.conf in order, waiting for a timeout between them.

Upstream has said this code hasn't been used or really tested in a long time.  Additionally, it waits 60 seconds before trying the next server in the /etc/yp.conf file, which could lead to long time before a server is found to bind to if the first servers in the yp.conf file aren't responding.

Version-Release number of selected component (if applicable):
ypbind-1.12-5.21.1.src.rpm

How reproducible:
Always

Steps to Reproduce:
Run tcpdump or ethereal when starting the ypbind service  

Additional info:

--- ypbind-mt-1.12/configure.bindings   2002-05-27 09:29:28.000000000 +0200
+++ ypbind-mt-1.12/configure    2004-09-20 15:15:48.061193257 +0200
@@ -5520,7 +5520,7 @@
    echo "***"
    ;;
  linux*)
-        USE_BROADCAST=1
+        USE_BROADCAST=0
       echo "$as_me:$LINENO: checking wether we have glibc 2.1 or later" >&5
echo $ECHO_N "checking wether we have glibc 2.1 or later... $ECHO_C" >&6
       cat >conftest.$ac_ext <<_ACEOF

Comment 2 Chris Feist 2005-03-31 23:26:44 UTC
I was unable to find a case where ypbind acted differently when USE_BROADCAST
was changed from 0 to 1.

I've removed the USE_BROADCAST section from the patch, but am unable to test
what it fixed.  It has been built into ypbind-1.12-5.21.6.  An errata is also
being filed.

Comment 14 Eric Hagberg 2005-04-29 18:49:12 UTC
Is an errata coming for this soon?

This sort of change is really unnacceptable for anyone who has been using ypbind
w/ Red Hat Linux for any length of time... especially after sweating a bunch of
changes that were needed in the code that then got thrown out by this
USE_BROADCAST change.

Comment 15 Chris Feist 2005-04-29 19:18:41 UTC
I believe that the fix will be in RHEL3U5.  (The fix being USE_BROADCAST is
reverted to its old setting, 1).

Comment 17 Eric Hagberg 2005-05-18 18:37:06 UTC
I don't see it in U5, which seems to be out now.

What happened?

Comment 18 Chris Feist 2005-05-18 18:55:08 UTC
What is the version of the rpm you have?  rpm -q ypbind.

Comment 19 Marty Wesley 2005-05-18 19:00:04 UTC
Check out ypbind-1.11-broadcast.patch in ypbind-1.12-5.21.6.src.rpm

Comment 20 Eric Hagberg 2005-05-19 19:40:16 UTC
ypbind-1.12-5.21.1.src.rpm is the latest src.rpm in the RHEL3, and that's from
20-Sep-04.

Comment 21 Eric Hagberg 2005-05-19 19:40:59 UTC
This is in RHN and via up2date.

Comment 22 Tim Powers 2005-05-20 00:55:50 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-355.html


Comment 23 Chris Feist 2005-05-23 22:11:47 UTC
It appears that rhn didn't push out the latest rpms all at the same time.  You
should have recieve ypbind-1.12-5.21.6 from up2date by now.  If not please
re-open this bug.


Note You need to log in before you can comment on or make changes to this bug.