Bug 15185 - WindowMaker Prefs
Summary: WindowMaker Prefs
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: WindowMaker   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-02 21:22 UTC by Jeff "Crash" Goldin
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-03 17:00:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff "Crash" Goldin 2000-08-02 21:22:31 UTC
Ok more than likely not a bug but a problem we are going to see in
support.  People who preform upgrades and use WindowMaker will run into
difficulties trying to use their old config files, since some of
WindowMaker files  like Wprefs have moved from
/usr/X11R6/lib/GNUstep/Apps/WPrefs.app to /usr/lib/GNUstep/Apps/WPrefs.app
also since other functional changes here made here like the removal of the
clip icon, and the functions droped into the applications menu.

Comment 1 Crutcher Dunnavant 2000-08-03 17:00:56 UTC
Okay, the directory change will mess with us, I'll look at it.
BUT, the removal of the clip icon will NOT hamper the installed base,
as it is only taken out of the global defaults (and anyone with their own
preferances, ie: anyone who is upgrading, has local defaults already)

Comment 2 Crutcher Dunnavant 2000-08-03 21:16:05 UTC
Okay,
I've looked at this, and this is just gonna break no matter what we do.
the only fixes would be to either:
A) Put a symlink in /usr/X11R6/lib (which is not what we want to do to keep this
running, when can we trash it?
- or -
B) make the Window Maker rpm recursively walk the home directorys and 'fix'
their config files, which is such the wrong thing I don't want to think about
it.

So we can't really fix this on upgrade, as the problem is in user config files.
I assume the archetecture change will go in the changelog,  so I'm gonna close
this as 'WONTFIX'


Note You need to log in before you can comment on or make changes to this bug.