Bug 151851 - ifcfg scripts lack the bootproto=dhcp line
ifcfg scripts lack the bootproto=dhcp line
Status: CLOSED DUPLICATE of bug 147760
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: ispec (Show other bugs)
2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Will Woods
Richard Li
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-22 16:33 EST by Jeff Lane
Modified: 2007-04-18 13:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-16 08:34:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Lane 2005-03-22 16:33:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; MSIE 5.5; WOPr)

Description of problem:
After performing a kickstart install using the ispec generaged kickstart scripts, on machines with multiple NICs, only eth0 has the proper BOOTPROTO line added to the ifcfg script.  All other ifcfg scripts are missing the BOOTPROTO line.  

So, when the tests run automatically after the install, the network test always fails because every NIC beyond eth0 never gets a dhcp assigned IP address.

Version-Release number of selected component (if applicable):
RHR2-rhel4-1.0-14a

How reproducible:
Always

Steps to Reproduce:
1.perform ispec generated kickstart install
2.run tests automatically
3.profit
  

Actual Results:  The network test fails because one or more NICs can not communicate with the network due to them not being configured with dhcp

Expected Results:  either a %post that includes the BOOTPROTO line in ifcfg (or just appends it to any ifcfg-eth scripts found, OR a prompt during the interactive portion of the automatic test run (before or right after USB tests) prompting tester to check ifcfg scripts.  If I run the tests manually using redhat-ready, I can edit the scripts before NETWORK runs, and the test is successful every time.

Additional info:
Comment 1 Rob Landry 2005-04-14 14:06:46 EDT
Moving to ispec component
Comment 2 Rob Landry 2006-05-16 08:34:39 EDT
this is a side effect of 147760

*** This bug has been marked as a duplicate of 147760 ***

Note You need to log in before you can comment on or make changes to this bug.