Bug 1518544 - [abrt] dnfdragora-gui: _g_log_abort(): python3.6 killed by SIGTRAP
Summary: [abrt] dnfdragora-gui: _g_log_abort(): python3.6 killed by SIGTRAP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnfdragora
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:bd39400dce90930d33277b0bfb5...
: 1535613 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-29 07:33 UTC by Tomas Toth
Modified: 2018-01-19 20:18 UTC (History)
11 users (show)

Fixed In Version: dnfdragora-1.0.1-8.git20171229.24e4647.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-31 21:28:55 UTC


Attachments (Terms of Use)
File: backtrace (101.34 KB, text/plain)
2017-11-29 07:33 UTC, Tomas Toth
no flags Details
File: cgroup (289 bytes, text/plain)
2017-11-29 07:34 UTC, Tomas Toth
no flags Details
File: core_backtrace (24.37 KB, text/plain)
2017-11-29 07:34 UTC, Tomas Toth
no flags Details
File: cpuinfo (1.05 KB, text/plain)
2017-11-29 07:34 UTC, Tomas Toth
no flags Details
File: dso_list (18.48 KB, text/plain)
2017-11-29 07:34 UTC, Tomas Toth
no flags Details
File: environ (2.14 KB, text/plain)
2017-11-29 07:34 UTC, Tomas Toth
no flags Details
File: limits (1.29 KB, text/plain)
2017-11-29 07:34 UTC, Tomas Toth
no flags Details
File: maps (89.26 KB, text/plain)
2017-11-29 07:34 UTC, Tomas Toth
no flags Details
File: mountinfo (3.47 KB, text/plain)
2017-11-29 07:34 UTC, Tomas Toth
no flags Details
File: open_fds (808 bytes, text/plain)
2017-11-29 07:34 UTC, Tomas Toth
no flags Details
File: proc_pid_status (1.27 KB, text/plain)
2017-11-29 07:34 UTC, Tomas Toth
no flags Details

Description Tomas Toth 2017-11-29 07:33:51 UTC
Description of problem:
It happens during KDE shutdown. At the next startup this bug is present in abrt-cli ls. Its time stamp matches the shutdown.

Version-Release number of selected component:
dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27

Additional info:
reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _g_log_abort
executable:     /usr/bin/python3.6
journald_cursor: s=08a2bf9dd63a4d4fbed4010cd94a1c53;i=112435;b=a3ea797861104572a60cb7de906aa62e;m=14feef0243;t=55f19b387565d;x=43c465c42a41a4c7
kernel:         4.13.15-300.fc27.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 _g_log_abort at gmessages.c:554
 #1 g_log_writer_default at gmessages.c:2628
 #2 g_log_structured_array at gmessages.c:1941
 #3 g_log_structured at gmessages.c:1768
 #10 XPending at Pending.c:55
 #11 gdk_check_xpending at gdkeventsource.c:269
 #12 gdk_event_source_check at gdkeventsource.c:306
 #13 g_main_context_check at gmain.c:3719
 #16 ffi_call_unix64 at ../src/x86/unix64.S:76
 #17 ffi_call at ../src/x86/ffi64.c:525

Comment 1 Tomas Toth 2017-11-29 07:33:59 UTC
Created attachment 1360191 [details]
File: backtrace

Comment 2 Tomas Toth 2017-11-29 07:34:01 UTC
Created attachment 1360192 [details]
File: cgroup

Comment 3 Tomas Toth 2017-11-29 07:34:03 UTC
Created attachment 1360193 [details]
File: core_backtrace

Comment 4 Tomas Toth 2017-11-29 07:34:04 UTC
Created attachment 1360194 [details]
File: cpuinfo

Comment 5 Tomas Toth 2017-11-29 07:34:06 UTC
Created attachment 1360195 [details]
File: dso_list

Comment 6 Tomas Toth 2017-11-29 07:34:07 UTC
Created attachment 1360196 [details]
File: environ

Comment 7 Tomas Toth 2017-11-29 07:34:09 UTC
Created attachment 1360197 [details]
File: limits

Comment 8 Tomas Toth 2017-11-29 07:34:11 UTC
Created attachment 1360198 [details]
File: maps

Comment 9 Tomas Toth 2017-11-29 07:34:13 UTC
Created attachment 1360199 [details]
File: mountinfo

Comment 10 Tomas Toth 2017-11-29 07:34:14 UTC
Created attachment 1360200 [details]
File: open_fds

Comment 11 Tomas Toth 2017-11-29 07:34:15 UTC
Created attachment 1360201 [details]
File: proc_pid_status

Comment 12 Sylvia Sánchez 2017-12-05 09:28:05 UTC
*** Bug 1520835 has been marked as a duplicate of this bug. ***

Comment 13 Fedora Update System 2017-12-29 23:24:30 UTC
dnfdaemon-0.3.18-5.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 14 Fedora Update System 2017-12-29 23:28:24 UTC
dnfdaemon-0.3.18-5.fc26 dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 15 Fedora Update System 2017-12-30 19:55:13 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 16 Fedora Update System 2017-12-30 20:41:00 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 17 Eugene Mah 2017-12-31 11:42:57 UTC
Similar problem has been detected:

Logged out and logged back in after installing DNF updates. Found crash report in abrt

reporter:       libreport-2.9.3
backtrace_rating: 3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _g_log_abort
executable:     /usr/bin/python3.6
journald_cursor: s=4b7f86b16e7d422380c0cd35b872e91a;i=54bc5;b=07532f4802874ba485c4253a6d434217;m=20ea2a1cb9;t=561a11b4a96cf;x=137a3ae8f20a9cf1
kernel:         4.14.8-300.fc27.x86_64
package:        dnfdragora-updater-1.0.1-8.git20171229.24e4647.fc27
reason:         python3.6 killed by SIGTRAP
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 18 Björn 'besser82' Esser 2017-12-31 12:19:19 UTC
(In reply to Eugene Mah from comment #17)
> Similar problem has been detected:
> 
> Logged out and logged back in after installing DNF updates. Found crash
> report in abrt
> 
> reporter:       libreport-2.9.3
> backtrace_rating: 3
> cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
> crash_function: _g_log_abort
> executable:     /usr/bin/python3.6
> journald_cursor:
> s=4b7f86b16e7d422380c0cd35b872e91a;i=54bc5;
> b=07532f4802874ba485c4253a6d434217;m=20ea2a1cb9;t=561a11b4a96cf;
> x=137a3ae8f20a9cf1
> kernel:         4.14.8-300.fc27.x86_64
> package:        dnfdragora-updater-1.0.1-8.git20171229.24e4647.fc27
> reason:         python3.6 killed by SIGTRAP
> rootdir:        /
> runlevel:       N 5
> type:           CCpp
> uid:            1000

Yeah, which is caused by having still an instance of the old updater running after the update.  This shouldn't happend anymore in the next logout.

Comment 19 Fedora Update System 2017-12-31 21:28:55 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2018-01-01 22:12:28 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 orti1980 2018-01-06 18:02:54 UTC
*** Bug 1531928 has been marked as a duplicate of this bug. ***

Comment 22 vikram goyal 2018-01-16 10:23:21 UTC
Similar problem has been detected:

dnf updated, rebooted & logged into the account when it crashed.

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        python3 /usr/bin/dnfdragora-updater
crash_function: _g_log_abort
executable:     /usr/bin/python3.6
journald_cursor: s=fb30be056aa442a3be1bcc9d571455a0;i=69f15;b=936c80b208f24fa090ebef3e1aa43164;m=4e319209db;t=562e1ede6b8c3;x=276cf65ed905b563
kernel:         4.14.11-300.fc27.x86_64
package:        dnfdragora-updater-1.0.1-9.git20180108.b0e8a66.fc27
reason:         python3.6 killed by SIGTRAP
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 23 sajjad 2018-01-17 18:11:42 UTC
*** Bug 1535613 has been marked as a duplicate of this bug. ***

Comment 24 D. Stimits 2018-01-19 20:15:19 UTC
Similar problem has been detected:

This occurs each logout/login...I don't know if it is at the logout, or if it is at the login. This and kactivitymanagerd both crash at the same time. If I clear all gnome-abrt knowledge of crashes, and then logout/login, these occur again as a pair. System is kept updated, this has not changed over many updates.

reporter:       libreport-2.9.3
backtrace_rating: 3
cmdline:        python3 /usr/bin/dnfdragora-updater
crash_function: _g_log_abort
executable:     /usr/bin/python3.6
journald_cursor: s=5a4c4fb700a04793b534ae20f2b941b7;i=451bd;b=519b4b07b6304dec8946cd834d7228a4;m=1abb9c8b;t=56326a121ef70;x=b16047d867172917
kernel:         4.14.13-300.fc27.x86_64
package:        dnfdragora-updater-1.0.1-9.git20180108.b0e8a66.fc27
reason:         python3.6 killed by SIGTRAP
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 25 D. Stimits 2018-01-19 20:18:14 UTC
Can this bug be re-opened? It is still present in Fedora 27.


Note You need to log in before you can comment on or make changes to this bug.