Bug 151858 - rpm -e fills up all available memory when trying to remove kernel rpms
rpm -e fills up all available memory when trying to remove kernel rpms
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-22 18:03 EST by James Chaumont
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: rpm-4.3.3-3.0.fc3.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-26 18:06:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Chaumont 2005-03-22 18:03:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:
When trying to use rpm -e to remove old kernel rpms, I get an error message saying: memory alloc (4 bytes) returned NULL.  Watching with top, I can see that rpm is using more and more memory until it fills all available space then dies with the alloc error message.  Before rpm runs 48 or so of 64MB are free.  I have 4 old kernel versions and I get this problem when attempting to remove any of them.  I have tried re-building the rpm db with "rpm --rebuilddb -vv" but it does not help.  Also, I tried "rm -f /var/lib/rpm/__db*" before rebuilding the db but it doesn't matter because there are no locks in that directory anyway.  I have seen a couple of instances online where users describe this problem, primarily with old versions of red hat, but have not come accross a solution anywhere.

Other functions of rpm, such as rpm -qa, seem to work fine.

Version-Release number of selected component (if applicable):
rpm-4.3.1-0.4.1

How reproducible:
Always

Steps to Reproduce:
1. run rpm -e kernel-2.6.10-1.8_FC2 (also happens with any of these other kernel rpms which are currently on the machine: kernel-2.6.10-1.9_FC2, kernel-2.6.10-1.770_FC2, kernel-2.6.10-1.12_FC2, kernel-2.6.10-1.14_FC2
  

Actual Results:  fills up all memory (observered with top)
fails with this error:  memory alloc (4 bytes) returned NULL.

Expected Results:  Should have successfully removed requested rpm.

Additional info:
Comment 1 Jeff Johnson 2005-04-01 15:26:15 EST
Upgrading to the version of rpm in FC3 will solve this problem.
Comment 2 Matthew Miller 2005-04-26 11:49:01 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 3 Paul Nasrat 2005-09-26 18:06:24 EDT
This is fixed in FC3 and later.

Note You need to log in before you can comment on or make changes to this bug.