Bug 151866 - %post script error "gcj-dbtool: command not found" when installing
Summary: %post script error "gcj-dbtool: command not found" when installing
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Phil Muldoon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-23 00:21 UTC by Orion Poplawski
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-27 23:33:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Orion Poplawski 2005-03-23 00:21:28 UTC
Description of problem:
Doing a kickstart install of fc4test1 and only selecting eclipse-cdt (with
--resolvedeps) results in the following error when running the %post scripts of
eclipse-cdt and eclipse-platform::

/var/tmp/rpm-tmp.69579: line 4: gcj-dbtool: command not found

Looks like a %PreReq line is missing.

Version-Release number of selected component (if applicable):
eclipse-cdt-2.0.2_fc-3.i386.

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Phil Muldoon 2005-03-23 16:00:01 UTC
Thanks for catching this. The eclipse-cdt is missing a Requires gcc-java. 

Comment 2 Andrew Overholt 2005-03-23 16:04:39 UTC
eclipse-platform should not have the error as it Requires: gcc-java (which is
what provides gcj-dbtool).

The other plugins (changelog, buzilla) will need to have gcc-java added to their
Requires.

CCing jpound

Comment 3 Orion Poplawski 2005-03-23 16:20:39 UTC
According to the install logs, gcc-java was installed after eclipse-cdt and
eclipse-platform.

Problem might be related to it being a slightly customized version of fc4test1.
 However I do use pkgorder when building.  I'll try with a plain rawhide install
and check.

Comment 4 Orion Poplawski 2005-03-23 17:22:02 UTC
See this with today's (unmodified) rawhide.

Comment 5 Phil Muldoon 2005-03-24 15:45:43 UTC
The new CDT with the Requires should be in Rawhide this morning (along with
updated CDT 3.0 M5 sources). Give that a try, and see how it works.

Comment 6 Orion Poplawski 2005-04-07 16:25:38 UTC
Finally got rawhide to install again.  Seeing something similar:

Installing eclipse-cdt-3.0.0_fc-0.M5.3.i386.
/var/tmp/rpm-tmp.70969: line 1: rebuild-gcj-db: command not found
error: %post(eclipse-cdt-3.0.0_fc-0.M5.3.i386) scriptlet failed, exit status 127
Installing eclipse-platform-3.1.0_fc-0.M5.17.i386.
/var/tmp/rpm-tmp.10476: line 1: rebuild-gcj-db: command not found
Installing gcc-java-4.0.0-0.40.i386.

So, maybe another dependency?

# rpm -qf /usr/bin/rebuild-gcj-db
java-1.4.2-gcj-compat-1.4.2.0-40jpp_14rh


Comment 7 Phil Muldoon 2005-04-07 16:37:16 UTC
Yes, this was a change recently made (they moved all the gcj db manipulation to
a convienient script). Looks like the requires needs to be tweaked to include
what you posted. Thanks again, for catching!

Comment 8 Orion Poplawski 2005-04-25 21:49:56 UTC
Appears to have cropped up again, different component:

Installing eclipse-ecj-3.1.0_fc-0.M6.10.i386.
/var/tmp/rpm-tmp.66871: line 1: /usr/bin/rebuild-gcj-db: No such file or directory
error: %post(eclipse-ecj-3.1.0_fc-0.M6.10.i386) scriptlet failed, exit status 127


Comment 9 Andrew Overholt 2005-04-25 22:04:20 UTC
I'm not sure why this happened to you.  We have java-1.4.2-gcj-compat in the
Requires(post,postun) for each sub-package.  I'll add a specific nvr of j-g-c
and see if that helps.  Watch for a new release tomorrow.

Comment 10 Jeremy Katz 2005-04-27 23:33:43 UTC
This should be fixed with the build of rpm that happened today.

Comment 11 Orion Poplawski 2005-05-24 21:37:09 UTC
No install messages on latest rawhide.  Closing again.


Note You need to log in before you can comment on or make changes to this bug.