Bug 1518707 - kernel: brk succeeds but fails to map memory on ppc64, ppc64le
Summary: kernel: brk succeeds but fails to map memory on ppc64, ppc64le
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PPCTracker 1518741
TreeView+ depends on / blocked
 
Reported: 2017-11-29 13:55 UTC by Florian Weimer
Modified: 2017-12-04 20:14 UTC (History)
21 users (show)

Fixed In Version: kernel-4.13.16-302.fc27 kernel-4.13.16-202.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1518741 (view as bug list)
Environment:
Last Closed: 2017-12-04 19:03:54 UTC


Attachments (Terms of Use)

Description Florian Weimer 2017-11-29 13:55:14 UTC
This commit

commit 6a72dc038b615229a1b285829d6c8378d15c2347
Author: Nicholas Piggin <npiggin@gmail.com>
Date:   Fri Nov 10 04:27:36 2017 +1100

    powerpc/64s/hash: Fix 128TB-512TB virtual address boundary case allocation

is required to fix a mm regression introduced in 4.12.  It has already been submitted for 4.14-stable, but I have not seen it elsewhere.

This bug causes a significant amount of glibc builds to fail on all branches, due to the way the build process uses the new glibc.

I would appreciate if this bug could be fixed on the Fedora builders even if the fix is not backported to the relevant stable kernels.

Comment 1 Jeremy Cline 2017-11-29 21:21:24 UTC
I included this in kernel-4.13.16-301.fc27 and kernel-4.13.16-301.fc26 which, if things go well, *should* make it to stable before Monday when the builders are scheduled to be updated.

Comment 2 Fedora Update System 2017-12-01 14:04:13 UTC
kernel-4.13.16-302.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-b0c1f44130

Comment 3 Fedora Update System 2017-12-01 14:04:52 UTC
kernel-4.13.16-202.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-9ea11e444d

Comment 4 Fedora Update System 2017-12-02 19:55:19 UTC
kernel-4.13.16-302.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-b0c1f44130

Comment 5 Fedora Update System 2017-12-02 22:39:48 UTC
kernel-4.13.16-202.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-9ea11e444d

Comment 6 Fedora Update System 2017-12-04 19:03:54 UTC
kernel-4.13.16-302.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2017-12-04 20:14:56 UTC
kernel-4.13.16-202.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.