Bug 151876 - No widescreen size options for Dell laptops exists.
No widescreen size options for Dell laptops exists.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hwdata (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-03-23 00:31 EST by Rodd Clarkson
Modified: 2015-03-04 20:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-01 11:35:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Results from inf2mondb.py for Dell monitors not in MonitorsDB (1.75 KB, text/plain)
2005-05-20 06:29 EDT, Fred New
no flags Details
MonitorsDB entries derived from Windows XP monitor*.inf files (30.31 KB, text/plain)
2005-05-20 06:55 EDT, Fred New
no flags Details

  None (edit)
Description Rodd Clarkson 2005-03-23 00:31:23 EST
Description of problem:

There's no options for widescreen Laptop Displays listed under Dell.

Options exist for:  
  Dell 1024x768 Laptop Display Panel
  Dell 1280x1024 Laptop Display Panel
  Dell 1400x1050 Laptop Display Panel
  Dell 1600x1200 Laptop Display Panel

The following resolutions should also be included:

  Dell 1280x800 Laptop Display Panel
  Dell 1440x900 Laptop Display Panel
  Dell 1600x1050 Laptop Display Panel
  Dell 1920x1200 Laptop Display Panel
Comment 1 Jeremy Katz 2005-04-27 19:34:06 EDT
Soeren -- did you add these when you synced up the list in rhpl?
Comment 2 Rodd Clarkson 2005-04-27 22:22:49 EDT
I'm not seeing any listing for these monitors in the current list (after an
update in rawhide today).

I don't mean to harp, but given how common these screen sizes are on Dell
laptops these days (and that Dell is a very popular brand) it would be great to
have this addressed.

While the screens do work, the way the current setting are cause all sorts of
screen artifacts that make things look (and act) very broken.
Comment 3 Rodd Clarkson 2005-04-27 22:24:49 EDT
Also, while this is being addressed, could I suggest that the display names get
changed to:

Dell Laptop Display Panel <width x height>

This would result in all the Laptop Diplay options appearing in the same chunk
of the listing, instead of being intermingled with other Dell monitors with
similar model numbers to the screen sizes.
Comment 4 Søren Sandmann Pedersen 2005-04-28 13:34:34 EDT
In Rawhide you should be able to select those resolutions from under "Generic
LCD Display".

Updating the Dell monitors would have to be done in hwdata, so reassigning there.

Comment 5 Bill Nottingham 2005-04-28 13:39:25 EDT
Would need some sort of INF for the Dell monitors before we could add specific
entries.
Comment 6 Rodd Clarkson 2005-05-17 20:44:27 EDT
Just a heads up.  I'm trying to find the INF file for this, but not having a lot
of luck.  I've not got Windows installed on the machine and the disks they
provide are all exe files that I imagine are just wrapped zip files, but I'm
unable to open them regardless.

I'm going to post a request for the file on the fedora-test list and see if
someone can come up with the goods.
Comment 7 Fred New 2005-05-20 06:29:44 EDT
Created attachment 114620 [details]
Results from inf2mondb.py for Dell monitors not in MonitorsDB

I downloaded all of the files in http://ftp.us.dell.com/monitors/, except for
those that looked like language variations, expanded them, ran the .inf files
through inf2mondb.py, and removed the lines that are already in MonitorsDB
(hwdata-0.145-1).  The result was these 29 lines.  As noted on
fedora-test-list, I don't have any of these monitors.  (I'm just trying to
teach myself Python.)
Comment 8 Fred New 2005-05-20 06:55:58 EDT
Created attachment 114621 [details]
MonitorsDB entries derived from Windows XP monitor*.inf files

And while we're at it, here are some additional monitors that Windows XP knows
about.	Judging by the EDIDs (inf2mondb.py's name for them), none of these are
in MonitorsDB, either.

Look out for EDID HWP22C8; there are 2 entries and the hsync and vsync numbers
are slightly different.  Probably best to leave it out of MonitorsDB
completely.

Also look out for lines beginning with "(Standard monitor types)".  These look
like generic entries.

The entries aren't in any particular order.  They're just the way they came
out of the 8 monitor*.inf files.
Comment 9 Phil Knirsch 2006-02-01 11:35:59 EST
All the Dell monitors are in the MonitorsDB now that were list in your comment
#7. The ones from comment #8 are partially already in the DB, so i need to
filter out whats duplicate and whats new.

Also, the problem is that e.g. Sony monitores are identified as SONY Corporation
now etc, so a big manual cleanup of those additional monitors would be needed
anyway.

I've saved the file in my hwdata CVS and see to include them over time.

As the original request has been done i'm closing this bug as fixed in rawhide.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.