Bug 151878 - Weird screen options when an LCD Panel 1920x1200 selected
Weird screen options when an LCD Panel 1920x1200 selected
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-23 00:43 EST by Rodd Clarkson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-29 16:49:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2005-03-23 00:43:40 EST
Description of problem:

When you select a LCD Panel 1920x1200 Monitor, the screen Resolutions in
settings are totally wack!

640x480, 800x600, 1028x768, 1280x960, 1280x1024, 1400x1050, 1600x1200 and
1920x1440 are all listed, but none of these are in the right aspect ratio for
the screen resolution chosen (1920x1200).  A 1920x1200 option doesn't even exist.

To make matters even weirder, the resolution displayed in the Screen Resolution
Preferences (Desktop > Preferences > Screen Resolution) don't compare to those
offered in system-config-display.

On offer are 1920x1200, 1680x1050, 1400x1050, 1280x800, 640x480, 800x600,
896x672, 928x696, 960x720.

Version-Release number of selected component (if applicable):

system-config-display-1.0.25-1


How reproducible:

Very


Additional info:

Trying to use the defaults as they stand product some very interesting screen
artifacts on my laptop.  (I've manually edited the xord.conf so that my display
works as expected, but don't think I should have to take such steps.)

I'm not sure if similar fun can be had on wide aspect LCD Displays of smaller sizes.
Comment 1 Søren Sandmann Pedersen 2005-04-28 16:50:14 EDT
Could you retest against rawhide, please?
Comment 2 Rodd Clarkson 2005-04-28 20:31:23 EDT
Okay, I rechecked and things are a little better.

Sizes available now include:

640x480, 800x600, 1028x768, 1152x864, 1280x800, 1280x960, 1280x1024, 1400x1050,
1680x1050, 1600x1200, 1920x1200 and 1920x1440

This is definitely an improvement.

A few suggestions/questions:

Given the the display isn't capable of more than 1920x1200 why is 1920x1440 offered?

Also, given the the display is widescreen, wouldn't it make more sense to only
offer the wide screen options.  This might involve the use of a toggle
below/above resolution that says "Limit to screen ratio" or "Show only native
resolutions" or something like that.  In this particular case, only 1280x800,
1680x1050 and 1920x1200 would appear by default, with the other resolutions
being made available if the toggle is changed.
Comment 3 Adam Jackson 2006-09-29 16:49:04 EDT
This should be resolved as of system-config-display 1.0.45-1.
Comment 4 Rodd Clarkson 2006-10-01 19:19:26 EDT
I know you've closed this, but I just wanted to confirm that it works for me.

Note You need to log in before you can comment on or make changes to this bug.