Bug 151886 - Rebuilding of gcc4 hangs up my system
Rebuilding of gcc4 hangs up my system
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-03-23 03:30 EST by Robert Scheck
Modified: 2015-01-04 17:17 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.11-1.1240_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-29 07:04:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the kernel panic via remote management card (7.02 KB, image/gif)
2005-04-14 17:00 EDT, Robert Scheck
no flags Details

  None (edit)
Description Robert Scheck 2005-03-23 03:30:27 EST
Description of problem:
Rebuilding of gcc4 hangs up my system, at least after 10 minutes of no reaction 
of the system the Automated System Recovery (ASR) of the HP ProLiant support 
pack comes up and reboots the server hard.

Okay, I wrote a log file using 'script' while rebuilding, but this file got
much bigger as 10 MB, so I only provide you the last 1000 lines with this bug
report.

Version-Release number of selected component (if applicable):
gcc-4.0.0-0.35
glibc-2.3.4-16

How reproducible:
Everytime, I simply try to rebuild gcc4 ;-)

Actual results:
Rebuilding of gcc4 hangs up my system

Expected results:
Rebuilding of gcc4 shouldn't hang up my system

Additional info:
The system is a ProLiant DL360 G3 with one CPU, the second CPU exists, because
of HyperThreading. The Kernel running is Rawhide SMP i686 from the last weekend 
(that kernel before 1191_FC4), but this shouldn't be that much relevant:

> cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Xeon(TM) CPU 3.06GHz
stepping        : 9
cpu MHz         : 3067.027
cache size      : 512 KB
physical id     : 3
siblings        : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de tsc msr pae mce cx8 apic mtrr pge mca cmov pat 
pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid xtpr
bogomips        : 6062.08

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Xeon(TM) CPU 3.06GHz
stepping        : 9
cpu MHz         : 3067.027
cache size      : 512 KB
physical id     : 3
siblings        : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de tsc msr pae mce cx8 apic mtrr pge mca cmov pat 
pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid xtpr
bogomips        : 6127.61

>
Comment 1 Robert Scheck 2005-03-23 03:31:28 EST
Oh and sorry - the gcc, I'm trying this rebuild with, is gcc-Version 4.0.0 
20050314 (Red Hat 4.0.0-0.34).
Comment 2 Jakub Jelinek 2005-03-23 07:55:07 EST
Assuming you build it as non-root user, if rebuilding gcc hangs the kernel, then
that can be either a kernel or hardware bug, not gcc's fault.
Rebuild of GCC certainly doesn't use insane emount of RAM, so unless you go with
too high make -jN or unless you are really low on memory RAM shouldn't be an
issue either.
Comment 3 Robert Scheck 2005-03-23 08:04:01 EST
Thanks for excluding this, maybe this report is a duplicate of bug #146344, 
but I can't see any oops' via ssh connections.

I'll test that using the latest rawhide kernel, changing to NEEDINFO.
Comment 4 Robert Scheck 2005-03-25 13:52:25 EST
Hrm, I only was able to reproduce the problem with -0.35 _several_ times (and 
even at different systems), with -0.37 I'm not able to reproduce. And I didn't 
change the kernel. For me, -0.37 solves the problem, closing now.
Comment 5 Robert Scheck 2005-04-14 16:59:17 EDT
Ha! I got it reproducable: The system freezes at rebuilding of gcc-4.0.0-0.42 
again and there exactly at:

Running /usr/src/redhat/BUILD/gcc-4.0.0-20050412/gcc/testsuite/gcc.c-torture/execute/execute.exp ...

The best: I've got a screenshot of the kernel panic via a remote management 
card...have fun at fixing ;-)
Comment 6 Robert Scheck 2005-04-14 17:00:50 EDT
Created attachment 113190 [details]
Screenshot of the kernel panic via remote management card
Comment 7 Dave Jones 2005-04-14 17:39:58 EDT
1208 is quite old now (theres a huge amount of code that changed since then due
to the rebase to 2.6.12-rc2). Can you reproduce this with the current kernel ?
Comment 8 Robert Scheck 2005-04-29 07:04:47 EDT
I was able to rebuild gcc4 -0.42 and -1 using kernel-2.6.11-1.1240_FC4; closing 
now.

Note You need to log in before you can comment on or make changes to this bug.