Bug 15190 - Random failures on installation over network
Random failures on installation over network
Status: CLOSED DUPLICATE of bug 17069
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-02 19:26 EDT by Dwayne McGarty
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-25 15:02:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dwayne McGarty 2000-08-02 19:26:49 EDT
On new installations kickstart fails because the system can't NFS mount the
directory containing the kickstart file and the RedHat pinstripe CD
contents.
Error is "I can't mount the directory".  Try manually typing in the NFS
source
mount path using both IP address and hostname with the same result.  After
installing the system using the http method and rebooting, the same NFS
source mount path has no problem.

As well we are getting random "Abnormal exits with Signal 11" at various
points
in the fresh installations using either the http or the ftp method.
Comment 1 Jeremy Katz 2000-08-05 15:35:56 EDT
Did you copy over the contents of both cds to the nfs directory?  This error
message is also given I believe when the NFS mounted directory does not contain
RedHat/instimage (which comes from the second CD, thus if you are nfs mounting a
loopback of CD1, it's not going to work).  Also, did you see any errors in the
logs on the NFS server regarding the failure to mount?
Comment 2 Dwayne McGarty 2000-08-08 17:52:19 EDT
CD data is copied onto the NFS volume.  ie this is not a loopback mount of an
iso image.  This
is an NFS volume that contains the contents of both cd1 and cd2.  The NFS server
is a
Network Appliance 720.  There are no error messages on the NFS server side.
Comment 3 Brock Organ 2000-08-09 12:52:15 EDT
hmmm ... We are not having those problems here in test ... could you attach a
copy of your kickstart file ...?
Comment 4 Dwayne McGarty 2000-08-09 15:15:30 EDT
Here is the kickstart file we have been using.  It is unmodified from the
version we are successfully using to deliver RedHat 6.2 to our machines.

---------------------------------------------------

lang en_US
keyboard us
# DHCP
network --bootproto dhcp
nfs --server cimnfs --dir /vol/vol0/linux
# Ethernet and others
# device ethernet 3c59x
# device ethernet 3c509
# device ethernet eepro100
# device ethernet rtl8139
# device ethernet ne2k-pci
# Partitions
zerombr yesclearpart --all
part /boot --size 25
part swap --size 100
#part / --size 750
part / --size 2000
#
install
#
# mouse ps/2 --emulthree
mouse generic3ps/2
#
timezone MST7MDT
#
xconfig --server "SVGA" --monitor "generic multisync"
#
rootpw byte1me
auth --enablenis --nisdomain wns_cim_prod --useshadow --enablemd5
#
#lilo --append 'anything-needed'
lilo --location mbr
%packages
@ Base
# @ Printer Support
# @ X Window System
@ Multimedia Support
@ Networked Workstation
@ NFS Server
@ SMB (Samba) Server
@ Authoring/Publishing
@ Utilities
gdm
autofs
xntp3
# XFree86-100dpi-fonts
pdksh
wu-ftpd
%post
/bin/mkdir /mnt/RPMS
/bin/mount 47.193.1.11:/vol/vol0/linux

/mnt/RPMS/Cim/hpevectra.sh

/bin/umount /mnt/RPMS


Comment 5 Michael Fulbright 2000-08-15 18:22:12 EDT
Please test this Brock.
Comment 6 Brock Organ 2000-08-15 18:59:06 EDT
after removing xntp3 from the package list, the above kickstart file works in
our test lab using the pinstripe public beta (as well as later RC-1) ...  

Can you try a recopy, or otherwise try to verify that the data from CD was
copied properly ... ?  Iffy, flaky or otherwise marginal CD drives have been
observed to do similar things in our test lab ... :(
Comment 7 Brock Organ 2000-08-31 16:13:10 EDT
Please reopen this if you are still seeing the problem and have more information
on how to reproduce the issue ... we haven't seen it in testing here ... thanks
for your report!
Comment 8 David Ross 2000-10-02 22:51:11 EDT
I work with Dwayne.
We have just done this experiment with RedHat 7.0.  We are kickstarting off of a bootable CDROM and using an NFS server for the install.
The NFS install fails right away with "Can't mount <path to RedHat install>".  This was when using our Network Appliance Filer as the NFS server.  For 
fun, I moved the RH7 image to our HP-UX 11 servers and tried it again.  Same result.  Then for kicks, we moved the image to one of our other Linux 
boxes.  It worked!!  It was then I noticed that our Linux box was running mountd with the flag "--no-nfs-version 3".  For even bigger kicks, I turned off the 
flag and tried kickstart again against our Linux box.  Failed the same as before!

It appears the NFS install fails if the NFS server is providing NFSv3 support.  Forcing NFSv2 only seems to fix it.  

This did not happen with RH6.2.  

Hope that helps!  We'd really like this to work!
Comment 9 Matt Wilson 2000-10-25 15:02:13 EDT
NFS bug consolidation
Comment 10 Matt Wilson 2000-10-25 15:02:28 EDT

*** This bug has been marked as a duplicate of 17069 ***

Note You need to log in before you can comment on or make changes to this bug.