Bug 151909 - upgrade from rh-postgresql to postgresql breaks system
upgrade from rh-postgresql to postgresql breaks system
Status: CLOSED DUPLICATE of bug 144435
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: postgresql (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-23 09:26 EST by Tuomo Soini
Modified: 2013-07-02 23:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-23 11:06:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tuomo Soini 2005-03-23 09:26:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Foobar/1.0.1-1.4.3.foo

Description of problem:
yum upgrade from rhel-3 rh-postgresql to rhel-4 postgresql fails because
wrong package obsoletes rh-postgresql-SUB_PACKAGE:s.

postgresql package obsoletes all rh-postgresql-* sub-packages while
postgresql-server should obsolete rh-postgresql-server.

Currently postgresql package has obsoletes for all sub-packages so update will remove all sub-packages leaving system without postgresql-server.

Version-Release number of selected component (if applicable):
postgresql-7.4.7--2.RHEL4.1

How reproducible:
Always

Steps to Reproduce:
1. have rhel-3
2. yum update to rhel-4
3. there is no postgresql-server package (or other postgresql-*) sub-packages.
  

Actual Results:  postgresql and postgresql-libs packages are installed on system. but all other sub-packages are missing.

Expected Results:  If rpm tag:

Obsoletes: rh-postgresql-server

was in correct sub-package, upgrade would have worked.

And same goes for other sub-packages.
postgresql-tcl should obsolete rh-postgresql-tcl etc.


Additional info:
Comment 1 Tom Lane 2005-03-23 11:06:49 EST
A fix for this is pending for RHEL4 U1.

*** This bug has been marked as a duplicate of 144435 ***

Note You need to log in before you can comment on or make changes to this bug.