Bug 15191 - "w" and "finger" logon list discrepancies
"w" and "finger" logon list discrepancies
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
7.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Preston Brown
Winston gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-02 19:31 EDT by Chris Evans
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-07 06:23:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Evans 2000-08-02 19:31:49 EDT
Apologies in advance, this is truly petty and minor!
May even be "NOTABUG"...
.
Anyway, if I use "w" to display logins, then a login via the GNOME gdm
login screen does not show up. Use of "finger" does show it.
.
Output of "finger":
[chris@localhost chris]$ finger
Login     Name       Tty      Idle  Login Time   Office     Office Phone
chris                tty1     1:24  Aug  1 06:27
chris               *:0             Aug  1 04:36
root      root       tty4     1:28  Aug  1 06:27

Output of "w":
[chris@localhost chris]$ w
  7:56am  up  3:21,  3 users,  load average: 0.00, 0.02, 0.02
USER     TTY      FROM              LOGIN@   IDLE   JCPU   PCPU  WHAT
chris    tty1     -                 6:27am  1:25m  0.15s  0.10s  -bash 
root     tty4     -                 6:27am  1:28m  0.09s  0.06s  -bash
Comment 1 Glen Foster 2000-08-04 11:19:51 EDT
This defect is considered MUST-FIX for Winston Gold-release
Comment 2 Tim Waugh 2000-08-07 06:23:29 EDT
w is skipping over the X login process since the process that added the utmp
entry (sessreg) is no longer around.  This makes it very hard to figure out
"what" that user is up to, and how much CPU time they've amassed.

My _guess_ is that this is expected behaviour and NOTABUG.
Comment 3 Preston Brown 2000-08-15 11:16:03 EDT
righto.

Note You need to log in before you can comment on or make changes to this bug.