Bug 151913 - Adding plugins doesn't work in a number of ways
Adding plugins doesn't work in a number of ways
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-23 10:05 EST by Brian G. Anderson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 13:12:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2005-03-23 10:05:51 EST
Description of problem:


Version-Release number of selected component (if applicable):
eclipse-jdt-3.1.0_fc-0.M5.13


How reproducible:
always


Steps to Reproduce:
1. select help->Software Updates->Find and Install
2. select the Search for new features to install
3. add new remote site;  I chose
http://www.perforce.com/downloads/http/p4-wsad/install/
4. select the new site and try to install
5a. take all the defaults and installation will complete, but nothing happens
5b. change the location of where the plugin will be installed to home direcotry;
installation almost completes but then hangs; restarting will clear it.

Actual results:

In the 5a case, no warning or message is given, but the plugin is not installed
In the 5b case, the platform hangs.


Expected results:
In the 5a case, either the default location should be the home directory, or a
warning should be issued that the target location is read only.

In the 5b case, the platform shouldn't hang.


Additional info:

I run eclipse 3.1M5 on FC3 using Sun JDK and this plugin works fine there.
Comment 1 Ben Konrath 2005-04-20 17:17:53 EDT
We just added a patch that automatically creates an installation location in
your home directory if ECLIPSE_HOME is not writable. I managed to install a
feature in my homedir when I was testing the patch so it seems to be working for
me. Can you please try this again with the latest packages? 

eclipse 3.1.0_fc-0.M6.7
gcc 4.0.0-0.42
Comment 2 Andrew Overholt 2005-05-04 10:27:19 EDT
I can't duplicate the problems outlined in the original report with our latest
packages (eclipse*-3.1.0_fc-0.M6.14, gcc*-4.0.0-2).  I also successfully
installed the subclipse plugin and it defaulted to my home directory as the
installation location.
Comment 3 Ben Konrath 2006-10-04 13:12:34 EDT
I can't duplicate the problems either, closing bug.

Note You need to log in before you can comment on or make changes to this bug.