Bug 151939 - bash segfault when killing background jobs
Summary: bash segfault when killing background jobs
Status: CLOSED DUPLICATE of bug 149213
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: bash (Show other bugs)
(Show other bugs)
Version: 2.1
Hardware: ia64 Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 151941 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-23 18:34 UTC by Franco M. Bladilo
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-24 16:34:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Franco M. Bladilo 2005-03-23 18:34:08 UTC
Description of problem:
Bash crashes with a segfault after killing background jobs.

Version-Release number of selected component (if applicable):
bash-2.05-8.2


How reproducible:
Always

Steps to Reproduce:
1. Execute bash
[root@management /]# bash
[root@management /]#

2. Background a job
[root@management /]# cat &
[1] 20043

3. Kill the job
[root@management /]# kill %1
                                                                               
                                                                             
[1]+  Stopped                 cat
4. Run another command
[root@management /]# pwd
/
Segmentation fault
  
Actual results:
Bash crashes.

Expected results:
succesfully kill a background job.

Additional info:

Comment 1 Tim Waugh 2005-03-23 18:50:23 UTC
*** Bug 151941 has been marked as a duplicate of this bug. ***

Comment 2 Franco M. Bladilo 2005-03-23 19:01:13 UTC
Software enviroment : 
glibc-2.2.4-32.18
libtermcap-2.0.8-28
kernel-2.4.18-e.41smp



Comment 3 Tim Waugh 2005-03-24 16:34:02 UTC

*** This bug has been marked as a duplicate of 149213 ***


Note You need to log in before you can comment on or make changes to this bug.