Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Descriptionsthirugn@redhat.com
2017-11-30 20:54:59 UTC
Description of problem:
Required space check is calculated incorrectly when there are mounted volumes
Version-Release number of selected component (if applicable):
satellite-clone-1.1.4-1.el7sat.noarch
How reproducible:
Always
Steps to Reproduce:
Code in pre_install_check.yml:
- name: find root partition's free space
set_fact:
root_free_space: "{{ (item.size_available | int) / 1000000000 }}"
cacheable: true
when: item.mount == "/"
with_items: "{{ hostvars[inventory_hostname] ['ansible_mounts'] }}"
The above logic ignores the mounted volume space so an error is thrown although the user has enough space on the mounted volumes.
Sample file system where this check failed:
$ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/root_vg-root_lv 2.0G 74M 2.0G 4% /
/dev/mapper/root_vg-usr_lv 6.0G 2.1G 4.0G 35% /usr
/dev/mapper/root_vg-home_lv 2.0G 33M 2.0G 2% /home
/dev/mapper/root_vg-var_lv 6.0G 2.2G 3.9G 36% /var
/dev/mapper/data_vg-rhsatVarLib_lv 800G 184M 800G 1% /var/lib
Actual results:
Space check failed although mounted volumes had a lot of space.
Expected results:
Space check logic should consider the mounted volumes too.
Additional info:
Comment 2sthirugn@redhat.com
2018-01-02 16:47:39 UTC
Workaround: Go to /etc/satellite-clone/satellite-clone-vars.yml -> Change the value of `required_root_free_space` to 0
Comment 3sthirugn@redhat.com
2018-01-02 16:49:05 UTC
*** Bug 1523790 has been marked as a duplicate of this bug. ***
As my bug (1523790) was merged into this one, I'd add this:
Per the 6.3 beta document, Upgrading and Updating Red Hat Satellite, the Before You Begin (2.1.2) section says this:
The target server must have capacity to store the backup files, which the source server transfers to the target server, and the backup files when they are restored.
This document does not say how much space the source server should have, or how to calculate how much space to provision. The command line entry only suggests an output directory of /backup/
In section 2.1.4, Step 10: The satellite-clone command does not specify which server the administrator should use.
Comment 5sthirugn@redhat.com
2018-01-15 20:30:53 UTC
*** Bug 1523495 has been marked as a duplicate of this bug. ***
Description of problem: Required space check is calculated incorrectly when there are mounted volumes Version-Release number of selected component (if applicable): satellite-clone-1.1.4-1.el7sat.noarch How reproducible: Always Steps to Reproduce: Code in pre_install_check.yml: - name: find root partition's free space set_fact: root_free_space: "{{ (item.size_available | int) / 1000000000 }}" cacheable: true when: item.mount == "/" with_items: "{{ hostvars[inventory_hostname] ['ansible_mounts'] }}" The above logic ignores the mounted volume space so an error is thrown although the user has enough space on the mounted volumes. Sample file system where this check failed: $ df -h Filesystem Size Used Avail Use% Mounted on /dev/mapper/root_vg-root_lv 2.0G 74M 2.0G 4% / /dev/mapper/root_vg-usr_lv 6.0G 2.1G 4.0G 35% /usr /dev/mapper/root_vg-home_lv 2.0G 33M 2.0G 2% /home /dev/mapper/root_vg-var_lv 6.0G 2.2G 3.9G 36% /var /dev/mapper/data_vg-rhsatVarLib_lv 800G 184M 800G 1% /var/lib Actual results: Space check failed although mounted volumes had a lot of space. Expected results: Space check logic should consider the mounted volumes too. Additional info: