Bug 1519811 - On upgrade from RHEV-3.6 to RHV-4, max_memory_size_mb seems hardly set to 1TB
Summary: On upgrade from RHEV-3.6 to RHV-4, max_memory_size_mb seems hardly set to 1TB
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.6
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ovirt-4.2.1
: ---
Assignee: Shmuel Melamud
QA Contact: Israel Pinto
URL:
Whiteboard:
Depends On:
Blocks: 1529927
TreeView+ depends on / blocked
 
Reported: 2017-12-01 13:37 UTC by Steffen Froemer
Modified: 2021-03-11 18:53 UTC (History)
13 users (show)

Fixed In Version: ovirt-engine-4.2.1.1
Doc Type: Bug Fix
Doc Text:
Previously, when upgrading from Red Hat Virtualization 4.0 to 4.1, the maximum memory size allocated for virtual machines was 1TB, which sometimes resulted in a virtual machine's actual memory size exceeding the allocated maximum memory size. In the current release, the allocated maximum memory size adjusts to the actual memory size.
Clone Of:
: 1529927 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:46:12 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3260021 0 None None None 2017-12-05 00:01:24 UTC
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:47:48 UTC
oVirt gerrit 85787 0 master MERGED core: Ensure that max_memory_size is not less than mem_size 2017-12-28 16:19:53 UTC
oVirt gerrit 85814 0 ovirt-engine-4.1 MERGED core: Ensure that max_memory_size is not less than mem_size 2017-12-31 09:12:27 UTC

Description Steffen Froemer 2017-12-01 13:37:46 UTC
Description of problem:
During upgrade from RHEV-3 to RHV-4, the cluster compatibility level can't be increased, as some VMs show inconsistency in definition of

  max_memory_size_mb
  mem_size_mb

Version-Release number of selected component (if applicable):
latest ovirt-engine

How reproducible:
always

Steps to Reproduce:
1. Setup a VM with mem_size_mb and min_allocated_mem to '1572864' in RHEV 3.6
2. upgrade RHEV database to RHV 4.1
3. check memory configuration in database

Actual results:
[root@dbview ~]# /usr/share/ovirt-engine/dbscripts/engine-psql.sh -c "select vm_name,mem_size_mb,min_allocated_mem,max_memory_size_mb from vm_static  where mem_size_mb >= '1048576' order by vm_name"
  vm_name   | mem_size_mb | min_allocated_mem | max_memory_size_mb
------------+-------------+-------------------+--------------------
 testvm-111 |     1572864 |           1572864 |            1048576
                                                           ^^^^^^^

Expected results:
[root@dbview ~]# /usr/share/ovirt-engine/dbscripts/engine-psql.sh -c "select vm_name,mem_size_mb,min_allocated_mem,max_memory_size_mb from vm_static  where mem_size_mb >= '1048576' order by vm_name"
  vm_name   | mem_size_mb | min_allocated_mem | max_memory_size_mb
------------+-------------+-------------------+--------------------
 testvm-111 |     1572864 |           1572864 |            1572864
                                                           ^^^^^^^

Additional info:

Comment 1 Germano Veit Michel 2017-12-03 23:27:51 UTC
Looks like some hardcoded value here:

04_01_0640_add_max_memory_size_column.sql

-- 1048576 is an old default from *MaxMemorySizeInMB config values
   SET max_memory_size_mb = LEAST(4 * mem_size_mb, 1048576);

Should it actually read the current *MaxMemorySizeInMB? Seems to be set to 4TB in CL 3.6.

Comment 2 Tomas Jelinek 2017-12-04 13:51:18 UTC
I'm sure you have already figured it out, but for completeness, the workaround is to issue this sql which will fix it:

update vm_static set max_memory_size_mb = mem_size_mb where mem_size_mb > max_memory_size_mb;

Comment 5 Israel Pinto 2018-01-18 11:57:45 UTC
Verify with: 4.2.1.1-0.1.el7

Steps:
1. Setup a VM with mem_size_mb and min_allocated_mem to '1572864' in RHEV 3.6
2. upgrade RHEV database to RHV 4.2 (4.0 -> 4.1 -> 4.2)
3. check memory configuration in database
Output:

engine=# select vm_name,mem_size_mb,min_allocated_mem,max_memory_size_mb from vm_static  where mem_size_mb >= '1048576' order by vm_name;
  vm_name   | mem_size_mb | min_allocated_mem | max_memory_size_mb 
------------+-------------+-------------------+--------------------
 bz_upgrade |     1572864 |           1572864 |            1572864
(1 row)

Comment 9 errata-xmlrpc 2018-05-15 17:46:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 10 Franta Kust 2019-05-16 13:04:41 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.