Bug 151984 - slow performance of 8139too driver
slow performance of 8139too driver
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-23 20:34 EST by igor
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-27 10:14:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description igor 2005-03-23 20:34:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050313 Fedora/1.7.6-0.cvs.20050313

Description of problem:
I have onboard realtek NIC:

00:12.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
        Subsystem: Sony Corporation: Unknown device 80ea
        Flags: bus master, medium devsel, latency 32, IRQ 3
        I/O ports at b000 [size=256]
        Memory at e5800000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2

The driver is 8139too.  Network performance is slow - I am getting 24Mb/s on 100Mb network.  When I was running RH8 on the same machine, I was getting over 90Mb/s.  On a different machine (3Com card) I am also getting over 90Mb/s, so I believe it's a Fedora+Realtek combination.  I am up to the latest revisions for all packages.  I measured NFS, scp and netcat speed, the numbers were consistent.


Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1191_FC4

How reproducible:
Always

Steps to Reproduce:
1. scp remote_machine:remote file . in 1 window
2. run iftop in another window and watch the speed of the transfer

Additional info:
Comment 1 John W. Linville 2005-05-25 16:30:54 EDT
Have you tried the 8139cp driver?  Devices that can work w/ the 8139cp driver 
should perform much better than using the same device w/ the 8139too driver. 
 
You can change "8139too" to "8139cp" in /etc/modprobe.conf in order to try it. 
Please do so and report the results.  Thanks! 
Comment 2 John W. Linville 2005-06-27 10:14:59 EDT
Closed due to lack of response...please reopen if/when the requested 
information becomes available... 

Note You need to log in before you can comment on or make changes to this bug.