Bug 151995 - mumble-config files are in the same location for 64-bit and 32-bit libs
mumble-config files are in the same location for 64-bit and 32-bit libs
Status: CLOSED DUPLICATE of bug 151980
Product: Fedora
Classification: Fedora
Component: libbonobo (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-23 22:26 EST by Jonathan Ryshpan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-24 14:59:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Ryshpan 2005-03-23 22:26:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
Most of the mumble-devel packages contain a library configuration file
called something mumble-config, which is installed as /usr/bin/mumble-
config.  This makes it impossible to install mumble-devel for both the
64-bit library and the 32-bit library on AMD x86_64 systems.  Which, in
turn, makes it impossible to develop many 32-bit applications on these
systems.

I suggest that these configuration files be separated by placing
them in (say) /usr/bin32 and /usr/bin64, to be used only for packages
with the same name that produce different results depending on the
desired architecture, or in /usr/lib and /usr/lib64, or /usr/lib/bin
and /usr/lib64/bin, or whatever?

Could be in FC4 for the AMD x86_64 processors.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. $ rpm --install libpng-devel-1.2.8-1.fc3.i386.rpm
2. (For an actual example)
3.
  

Actual Results:  file /usr/bin/libpng12-config from install of libpng-devel-1.2.8-1.fc3 conflicts with file from package libpng-devel-1.2.8-1.fc3

Expected Results:  libpng-devel-1.2.8-1.fc3 should install (i.e. no output should appear)

Additional info:

This bit me while trying to build a 32-bit version of mplayer,
which is needed to access most of the publicly available codecs.
Development would have been easy otherwise -- just 
        export CC="cc -m32" 
before running configure.

Please accept my apology for using the component "bonobo".  There
doesn't seem to be a component ("all"?) for this kind of problem.
Comment 1 Jonathan Ryshpan 2005-03-24 14:59:24 EST

*** This bug has been marked as a duplicate of 151980 ***

Note You need to log in before you can comment on or make changes to this bug.