Bug 152008 - gphoto2 bad RPATHs
Summary: gphoto2 bad RPATHs
Status: CLOSED DUPLICATE of bug 145439
Alias: None
Product: Fedora
Classification: Fedora
Component: gphoto2   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-24 10:59 UTC by Warren Togami
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-24 11:07:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Warren Togami 2005-03-24 10:59:40 UTC
twaugh mentioned that he was unable to fix this.  Maybe others can help.

+ /usr/lib/rpm/check-rpaths /usr/lib/rpm/check-buildroot
ERROR: file '/usr/lib/gphoto2_port/0.5.1/libgphoto2_port_serial.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2_port/0.5.1/libgphoto2_port_usb.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/libgphoto2.so.2.0.3' contains an invalid rpath
'/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_agfa_cl20.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_aox.so' contains an invalid rpath
'/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_barbie.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_canon.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_casio_qv.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_digita.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_dimera3500.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_directory.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_fuji.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_gsmart300.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_iclick.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_jamcam.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_jd11.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_kodak_dc120.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_kodak_dc210.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_kodak_dc240.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_kodak_dc3200.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_ez200.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_konica.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_konica_qm150.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_largan.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_mars.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_dimagev.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_mustek.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_panasonic_coolshot.so' contains
an invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_panasonic_l859.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_panasonic_dc1000.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_panasonic_dc1580.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_pccam300.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_pccam600.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_polaroid_pdc320.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_polaroid_pdc640.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_polaroid_pdc700.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_ptp2.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_ricoh.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_ricoh_g3.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_samsung.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_sierra.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_sipix_blink.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_sipix_blink2.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_sipix_web2.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_smal.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_sony_dscf1.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_sony_dscf55.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_soundvision.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_spca50x.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_sq905.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_stv0674.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_stv0680.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_sx330z.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_toshiba_pdrm11.so' contains an
invalid rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in
[/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/gphoto2/2.1.5/libgphoto2_enigma13.so' contains an invalid
rpath '/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]
ERROR: file '/usr/lib/libgphoto2/print-usb-usermap' contains an invalid rpath
'/var/tmp/gphoto2-2.1.5-root/usr/lib' in [/var/tmp/gphoto2-2.1.5-root/usr/lib]

Comment 1 Tim Waugh 2005-03-24 11:07:36 UTC

*** This bug has been marked as a duplicate of 145439 ***

Comment 2 Sammy 2005-03-24 16:09:29 UTC
I am not getting these messages when I build gphoto2 from source rpm. The only 
difference I can see is that I am building/using my own libexif rpms since I need 
to have libexif at least 0.6.9 (I have 0.6.12) whereas the version in the development 
tree is 0.5.12. 


Note You need to log in before you can comment on or make changes to this bug.