Bug 152031 - [RFE] caption package is [1995/04/05 v1.4b]. Current version is [2004/11/28 v3.0d]
[RFE] caption package is [1995/04/05 v1.4b]. Current version is [2004/11/28 v...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-24 10:48 EST by Marc Schwartz
Modified: 2013-07-02 19:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 12:13:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Schwartz 2005-03-24 10:48:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
In attempting to use the caption package, I was getting errors regarding unknown options. 

For example:

\usepackage[format=hang,font=bf,belowskip=10pt,singlelinecheck=false]{caption}

After trying to debug the code, it became evident that the current default caption packge in FC3 is about 10 years old. The older version, of course,   does not support new options as they are referenced in most current LaTeX books (ie. TLC).


Version-Release number of selected component (if applicable):
tetex-latex-2.0.2-21.3

How reproducible:
Always

Steps to Reproduce:
Use:

usepackage[format=hang,font=bf,belowskip=10pt,singlelinecheck=false]{caption}

in the document preamble.


Actual Results:  Error messages regarding unknown options in the caption package. The options are of course ignored by LaTeX.


Expected Results:  A properly formatted float caption.


Additional info:

Current caption package is located at:

http://www.ctan.org/tex-archive/help/Catalogue/entries/caption.html

A workaround for now is to install the new package. I did this in my local tex tree and ran texhash. This now enables the recognition of the updated options for the caption package.
Comment 1 Jindrich Novy 2005-03-25 02:16:23 EST
Hello Marc,

maybe the best solution for the issue will be upgrading your teTeX to 3.0, what
is now in rawhide and also in FC4t1. The new teTeX contains many fixes and new
packages, also containing the new caption. The \usepackage inclusion you
presented works fine with teTeX-3.0.
Comment 2 Marc Schwartz 2005-03-25 08:50:43 EST
Jindrich,

Thanks for your reply. I had not checked rawhide to see if there were any
updates there, but will look to that as an option.

Just for clarification, is this a situation where FC waits for the upstream full
package updates rather than including updated components as they are released by
their authors?

Thanks.
Comment 3 Jindrich Novy 2005-03-25 09:32:45 EST
Well, of course updates with the new upstream release is preferred, but in case
of packages such as teTeX, which is composed from a variety of packages
developed roughly separately by upstream it's common to release an update of the
whole teTeX when there exist several requests from users for obsolete subpackage
upgrades.
Comment 4 Marc Schwartz 2005-03-25 11:09:36 EST
Jindrich,

Thanks again for the clarification.

A follow up question, which may be helpful to others taking the same approach.

I installed the updated TeTeX packages, which has indeed solved the problem
relative to caption.

Under the older packages, I had been using aucTeX and preview-latex under
XEmacs, which worked reasonably well together. I had installed the updated
packages from their respective web sites.

If my read is correct, it looks like aucTeX version "close to 12" is installed
(11.55 available on the web site) in the new TeTeX packages along with
preview-latex (version unclear).

I can get aucTeX to work in XEmacs, but cannot seem to get preview-latex to come
up, though I have not changed anything in the .el config files.

Is there some modifcation that I need to make or is this possibly a bug that
needs to get reported, recognizing that this is now a mix of rawhide and FC3?

I installed the updated emacs RPMS from rawhide, but did not see anything for
Xemacs there.

Thanks.
Comment 5 Jindrich Novy 2005-03-29 10:12:34 EST
Marc,

I think this looks like a specific Emacs problem here. I'm unfortunately not
very much experienced with it as I'm vim user actualy ;)

Jens, could you please help here?
Comment 6 Marc Schwartz 2005-03-30 09:19:45 EST
Jindrich,

Thanks for your help again.

I won't hold your being a vim user against you...  ;-)

Just to be clear for Jens, the problem with preview-latex is happening with both
emacs and xemacs.

Thanks.
Comment 7 Jens Petersen 2005-04-03 23:21:45 EDT
Tetex includes auctex these days?

At least for XEmacs, auctex is included in xemacs-sumo.
Is that auctex also giving you problems?

[[cc Ville, the new xemacs maintainer for Fedora Extras]]

ps Anyway probably better to file a separate bug bug about
the auctex issue. :)
Comment 8 Marc Schwartz 2005-04-04 14:56:30 EDT
Jens,

Thanks for the follow up.

I am still somewhat unclear as to just what changed upon the install of TeTeX 3
relative to preview-latex. It had been working under the prior version without
problem.

Be that as it may, I installed a just updated version of preview-latex this
morning (version 0.9.1), which in turn required that I install an auctex RPM (>
11.0) during the dependency check. I downloaded both from
http://ftp.gnu.org/pub/gnu/auctex/.

Having now installed these, preview-latex is working within Xemacs and emacs.

If there is something that you would like me to investiage further, let me know.

Otherwise, I suspect we can close this one out.

Thanks to both Jens and Jindrich for your help with this.
Comment 9 Jindrich Novy 2005-04-05 12:13:28 EDT
Ok, I'm glad it's not that serious. I'll consider releasing FC update for
teTeX-3.0 after some testing period in devel. Thanks.

Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.