Bug 1520360 - ship libinput and libevdev on ComputeNode-optional
Summary: ship libinput and libevdev on ComputeNode-optional
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lubos Kocman
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-04 11:03 UTC by Tomas Pelka
Modified: 2018-04-10 10:21 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 10:20:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0700 None None None 2018-04-10 10:21:18 UTC

Description Tomas Pelka 2017-12-04 11:03:46 UTC
Description of problem:
For some reason libinput appearing on rhel7.5 on 7ComputeNode-optional and causing unresolved deps 

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
Error: Package: libinput-1.8.4-2.el7.x86_64 (/libinput-1.8.4-2.el7.x86_64)
           Requires: libevdev.so.2(LIBEVDEV_1_3)(64bit)
Error: Package: libinput-1.8.4-2.el7.x86_64 (/libinput-1.8.4-2.el7.x86_64)
           Requires: libmtdev.so.1()(64bit)
Error: Package: libinput-1.8.4-2.el7.x86_64 (/libinput-1.8.4-2.el7.x86_64)
           Requires: libevdev.so.2()(64bit)
Error: Package: libinput-1.8.4-2.el7.i686 (/libinput-1.8.4-2.el7.i686)
           Requires: libmtdev.so.1
Error: Package: libinput-1.8.4-2.el7.i686 (/libinput-1.8.4-2.el7.i686)
           Requires: libevdev.so.2
Error: Package: libinput-1.8.4-2.el7.i686 (/libinput-1.8.4-2.el7.i686)
           Requires: libevdev.so.2(LIBEVDEV_1_3)
Error: Package: libinput-1.8.4-2.el7.x86_64 (/libinput-1.8.4-2.el7.x86_64)
           Requires: libevdev.so.2(LIBEVDEV_1)(64bit)
Error: Package: libinput-1.8.4-2.el7.i686 (/libinput-1.8.4-2.el7.i686)
           Requires: libevdev.so.2(LIBEVDEV_1)


Expected results:


Additional info:
It was pulled in most probably because of Wayland

Comment 7 Lubos Kocman 2017-12-04 12:35:31 UTC
No change needed from RCM, all packages are pulled into 7.5 compose via depsolving and will be shipped as part of Beta, Snapshot, GA compose push.

Change itself will not be propagated to advisory, since there is no update of libevdev / libinput is 7.5.

If this would be a problem to anybody we can respin following Xorg advisory https://errata.devel.redhat.com/advisory/26253 

Moving to modified

Comment 13 errata-xmlrpc 2018-04-10 10:20:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0700


Note You need to log in before you can comment on or make changes to this bug.