Bug 1520363 - The pod should not be able to access external when the egressIP set to multiple netns
Summary: The pod should not be able to access external when the egressIP set to multi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.10.0
Assignee: Dan Winship
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-04 11:11 UTC by Meng Bo
Modified: 2018-07-30 19:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:09:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
openflow_dump_on_both_node (10.99 KB, text/plain)
2017-12-04 11:11 UTC, Meng Bo
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:09:46 UTC

Description Meng Bo 2017-12-04 11:11:55 UTC
Created attachment 1362632 [details]
openflow_dump_on_both_node

Description of problem:
Add the egressIP which is holding by any node to multiple netns. The pod in the project should loss the external access.

Version-Release number of selected component (if applicable):
v3.7.11

How reproducible:
always

Steps to Reproduce:
1. Setup multinode env with multitenant or networkpolicy plugin

2. Add the egressIP to any of the node
oc patch hostsubnet node1 -p "{\"egressIPs\":[\"$EGRESS_IP\"]}"

3. Assign the egressIP above to multiple netns
oc patch netnamespace project1 -p "{\"egressIPs\":[\"$EGRESS_IP\"]}"
oc patch netnamespace project2 -p "{\"egressIPs\":[\"$EGRESS_IP\"]}"

4. Create pod in all of the projects and try to access the outside


Actual results:
The pod in the first project can access external network through the egressIP.
The pod in the second project can access external network through the node IP.

Expected results:
All the pods in both projects should not be able to access external network.

Additional info:

Comment 1 Dan Winship 2018-03-02 15:33:33 UTC
https://github.com/openshift/origin/pull/18808

Comment 2 Dan Winship 2018-05-21 12:00:15 UTC
oops, this never got bumped to MODIFIED, but it's been fixed for a while now...

Comment 4 Meng Bo 2018-06-07 09:11:46 UTC
Issue has been fixed on v3.10.0-0.58.0

Comment 6 errata-xmlrpc 2018-07-30 19:09:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.