Bug 1520387
| Summary: | Re-initialize data center from unattached domain does not function. "Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) : Cannot read property 'className' of undefined" | ||||||
|---|---|---|---|---|---|---|---|
| Product: | [oVirt] ovirt-engine | Reporter: | Elad <ebenahar> | ||||
| Component: | Frontend.WebAdmin | Assignee: | shani <sleviim> | ||||
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Elad <ebenahar> | ||||
| Severity: | high | Docs Contact: | |||||
| Priority: | unspecified | ||||||
| Version: | 4.2.0 | CC: | amureini, bugs, ratamir, sleviim | ||||
| Target Milestone: | ovirt-4.2.0 | Keywords: | Regression | ||||
| Target Release: | --- | Flags: | rule-engine:
ovirt-4.2+
rule-engine: blocker+ |
||||
| Hardware: | x86_64 | ||||||
| OS: | Unspecified | ||||||
| Whiteboard: | |||||||
| Fixed In Version: | ovirt-engine-4.2.0.1 | Doc Type: | If docs needed, set a value | ||||
| Doc Text: | Story Points: | --- | |||||
| Clone Of: | Environment: | ||||||
| Last Closed: | 2017-12-20 10:51:05 UTC | Type: | Bug | ||||
| Regression: | --- | Mount Type: | --- | ||||
| Documentation: | --- | CRM: | |||||
| Verified Versions: | Category: | --- | |||||
| oVirt Team: | Storage | RHEL 7.3 requirements from Atomic Host: | |||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||
| Embargoed: | |||||||
| Attachments: |
|
||||||
Shani, can you take a look, please? Is this related to your recent work? This bug report has Keywords: Regression or TestBlocker. Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP. Hi, It isn't related to my last changes: After a check I made, the error message also appears on commit f0b58eeb4c385c2a41ff62e3775eb401b259c906 (which is one commit before my earliest patch). Still checking for the root cause. This fix is actually included in ovirt-engine-4.2.0.1. Moving to ON_QA. Re-initialize DC from an unattached domain works as expected via Webadmin. Used: rhvm-4.2.0.2-0.1.el7.noarch ovirt-engine-webadmin-portal-4.2.0.2-0.1.el7.noarch This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017. Since the problem described in this bug report should be resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE. If the solution does not work for you, please open a new bug report. |
Created attachment 1362651 [details] ui.log, engine.log and server.log Description of problem: Cannot re-initialize data center from unattached domain. In ui.log I got the following exception: 2017-12-04 13:47:22,810+02 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-15) [] Permutation name: 55FF90143BFA65053788DBB73BDE6B95 2017-12-04 13:47:22,810+02 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-15) [] Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) : Cannot read property 'className' of undefined at java.lang.Throwable.Throwable(Throwable.java:70) [rt.jar:1.8.0_151] at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_151] at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:64) [gwt-servlet.jar:] at Unknown.new b0(webadmin-0.js) at com.google.gwt.event.shared.HandlerManager.$fireEvent(HandlerManager.java:117) [gwt-servlet.jar:] at com.google.gwt.user.client.ui.Widget.$fireEvent(Widget.java:127) [gwt-servlet.jar:] at com.google.gwt.user.client.ui.Widget.fireEvent(Widget.java:127) [gwt-servlet.jar:] Version-Release number of selected component (if applicable): rhvm-4.2.0-0.5.master.el7.noarch ovirt-engine-webadmin-portal-4.2.0-0.5.master.el7.noarch google-chrome-stable-61.0.3163.100-1.x86_64 firefox-55.0.3-1.fc25.x86_64 How reproducible: Always, with Chrome and Firefox Steps to Reproduce: 1. Click on "Re-initialize data center" Actual results: Opertation fails with the mentioned exception in ui.log and with the following in Webadmin: Uncaught exception occurred. Please try reloading the page. Details: Exception caught: (TypeError) : Cannot read property 'className' of undefined Please have your administrator check the UI logs Expected results: Re-initialize DC should succeed. Additional info: ui.log, engine.log and server.log