Bug 1520393 - [RFE] Better error message for file transfer fail while no applicable filename for Windows OS [NEEDINFO]
Summary: [RFE] Better error message for file transfer fail while no applicable filenam...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: spice-vdagent-win
Version: 8.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Frediano Ziglio
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On: 1817451 1817471 1837489
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-04 12:15 UTC by Radek Duda
Modified: 2020-11-04 03:17 UTC (History)
17 users (show)

Fixed In Version: spice-vdagent-win-0.10.0-4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-04 03:17:29 UTC
Type: Feature Request
Target Upstream Version:
fziglio: needinfo? (djasa)


Attachments (Terms of Use)
Error message with multiple file transfer (21.40 KB, image/png)
2020-05-20 13:15 UTC, Frediano Ziglio
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:4721 None None None 2020-11-04 03:17:34 UTC

Description Radek Duda 2017-12-04 12:15:06 UTC
Description of problem:

If I transfer any file from rhel client, which has any of following symbols: '",|,<,>,?,*,:,\,/,' then errormessage appears with notice: 

"An error caused the following transfers to fail: $filename". 
It is not obvious from this message why transfer fails.
I know that in Windows OS are those symbols forbidden for naming files. But in RHEL it is possible to use even those weird symbols. I propose to have some more pleasant and more specific message there.

Something like:

"An error caused the following transfers to fail: $filename. Bad file name. $forbiddensymbol symbol in file name is not applicable for Windows OS."

Version-Release number of selected component (if applicable):
rhel 7.5 client:
virt-viewer-5.0-9.el7.x86_64
spice-gtk3-0.34-2.el7.x86_64

win7/win10 guest:
vdagent-win-4.1-5

How reproducible:
always

Steps to Reproduce:
1. Drag and drop file the name of which includes any of the symbol: '",|,<,>,?,*,:,\,/,' from client to guest VM with preinstalled Windows OS
2. See error message
3.

Actual results:
above

Expected results:
above

Additional info:

Comment 1 Frediano Ziglio 2018-05-25 13:14:55 UTC
Merged a patch at https://gitlab.freedesktop.org/spice/win32/vd_agent/commit/e2ced9f094bf676856ae78779f4a791936eb535f.

Should we have a release?
Close the bug?

Comment 2 Victor Toso 2018-05-25 13:28:45 UTC
(In reply to Frediano Ziglio from comment #1)
> Merged a patch at
> https://gitlab.freedesktop.org/spice/win32/vd_agent/commit/
> e2ced9f094bf676856ae78779f4a791936eb535f.


No. Your patched fixed a bug but did not implement the RFE.
The RFE is about error message itself, something that we have in the linux agent already with:

https://gitlab.freedesktop.org/spice/linux/vd_agent/commit/ca89a0102cd1
 
> Should we have a release?
> Close the bug?

After implementing the RFE we want to add it in RHV, with errata, etc.

Comment 3 Sandro Bonazzola 2019-01-28 09:40:57 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 8 Martin Tessun 2019-11-25 08:35:55 UTC
Looks like this has been implemented already. We can probably close this.
@David, could you check?

Comment 9 Sandro Bonazzola 2019-11-25 11:29:27 UTC
I think we are missing a build (both upstream and downstream)
Tag 0.10.0 has been created: https://gitlab.freedesktop.org/spice/win32/vd_agent/commit/58bc1b958054b5e1e1c5d0fd914e30b64c30653e
but the build is missing: https://www.spice-space.org/download/windows/vdagent/

Comment 10 Frediano Ziglio 2020-05-15 08:15:33 UTC
Still waiting for reviews

Comment 11 Victor Toso 2020-05-20 04:11:26 UTC
This RFE needs changes in spice-protocol, spice-gtk and the agent (this bug).

Spice-protocol fix will be included in rebase bug 1817451
* f224422 "vd_agent: Add a new detail for VD_AGENT_FILE_XFER_STATUS_ERROR status" in 2020-03-19 

Spice-gtk fix will be included in rebase bug 1817471
* d79b05d "channel-main: Handle some detailed error for VD_AGENT_FILE_XFER_STATUS_ERROR" in 2020-05-15

If all changes needed in upstream windows agent is merged, should be safe to move this one to POST too!

Comment 12 Frediano Ziglio 2020-05-20 09:38:29 UTC
(In reply to Victor Toso from comment #11)
> This RFE needs changes in spice-protocol, spice-gtk and the agent (this bug).
> 
> Spice-protocol fix will be included in rebase bug 1817451
> * f224422 "vd_agent: Add a new detail for VD_AGENT_FILE_XFER_STATUS_ERROR
> status" in 2020-03-19 
> 
> Spice-gtk fix will be included in rebase bug 1817471
> * d79b05d "channel-main: Handle some detailed error for
> VD_AGENT_FILE_XFER_STATUS_ERROR" in 2020-05-15
> 
> If all changes needed in upstream windows agent is merged, should be safe to
> move this one to POST too!

I would add that unfortunately these are not enough.
Currently virt-viewer through away the detailed errors from spice-gtk not showing them.

Comment 13 Victor Toso 2020-05-20 10:22:54 UTC
(In reply to Frediano Ziglio from comment #12)
> I would add that unfortunately these are not enough.
> Currently virt-viewer through away the detailed errors from spice-gtk not
> showing them.

I could not find a fix in git master upstream, are there any work pending review? We could bring the fix together with bug 1837489 (without the need to open a new bug in virt-viewer just for this backport)

Moving to POST, feel free to revert if you don't agree :)

Comment 14 Frediano Ziglio 2020-05-20 13:15:12 UTC
Created attachment 1690241 [details]
Error message with multiple file transfer

Comment 22 errata-xmlrpc 2020-11-04 03:17:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (spice-vdagent-win bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:4721


Note You need to log in before you can comment on or make changes to this bug.