Bug 1520396 - ibus show weird ui on desktop
Summary: ibus show weird ui on desktop
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: imsettings
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-04 12:18 UTC by vt
Modified: 2017-12-27 03:56 UTC (History)
5 users (show)

Fixed In Version: imsettings-1.7.3-1.fc27 imsettings-1.7.3-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-19 19:47:02 UTC


Attachments (Terms of Use)
ibus-ui-gtk (1.07 MB, image/png)
2017-12-04 12:18 UTC, vt
no flags Details

Description vt 2017-12-04 12:18:02 UTC
Created attachment 1362654 [details]
ibus-ui-gtk

Description of problem:

There is a weird ui show up on my desktop, and I figured out that it comes from ibus-ui-gtk3 because after I killed the process of ibus-ui-gtk3, it disappears. Check the attached screenshot.

This happened days ago, but I have no idea where it comes from at that moment, so I'm not sure whether it happens after I do 'dnf upgrade' or not.

Version-Release number of selected component (if applicable):

ibus-1.5.17-1.fc26.x86_64/ibus-1.5.17-1.fc27.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Boot up system
2. The weird ui show up at top-right or top-left of the screen, it can be dragged around. It shows on top of any other app windows.

Actual results:
Weird UI.

Expected results:


Additional info:

Comment 1 fujiwara 2017-12-05 10:17:47 UTC
ibus-ui-gtk3 is no longer launched in GNOME desktop so it should not happen.
I don't know which part is the handler GUI but it might be Property Panel.
You can hide the GUI with ibus-setup -> "Do not show" in Show property panel if the GUI is the part of Property Panel.

Comment 2 vt 2017-12-05 11:59:05 UTC
(In reply to fujiwara from comment #1)
> ibus-ui-gtk3 is no longer launched in GNOME desktop so it should not happen.
> I don't know which part is the handler GUI but it might be Property Panel.
> You can hide the GUI with ibus-setup -> "Do not show" in Show property panel
> if the GUI is the part of Property Panel.

I didn't see "Do not show" option, but I have "Show icon on system tray" unchecked under "General" tab, it doesn't help.

ibus-ui-gtk3 is always launched on my system after boot up. I used xwininfo to check where the ui comes from:

$ xwininfo 

xwininfo: Please select the window about which you
          would like information by clicking the
          mouse in that window.

xwininfo: Window id: 0x60000f "ibus-ui-gtk3"

  Absolute upper-left X:  1917
  Absolute upper-left Y:  67
  Relative upper-left X:  1917
  Relative upper-left Y:  67
  Width: 6
  Height: 200
  Depth: 24
  Visual: 0x1a0
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x600002 (not installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: yes
  Map State: IsViewable
  Override Redirect State: yes
  Corners:  +1917+67  --3+67  --3-813  +1917-813
  -geometry 6x200--3+67

The packages installed on my system:

$ rpm -qa | grep ibus | grep -v 'libus'
ibus-1.5.17-1.fc27.x86_64
ibus-setup-1.5.17-1.fc27.noarch
ibus-wayland-1.5.17-1.fc27.x86_64
ibus-gtk3-1.5.17-1.fc27.x86_64
ibus-libs-1.5.17-1.fc27.x86_64
ibus-gtk2-1.5.17-1.fc27.x86_64

Comment 3 fujiwara 2017-12-06 05:09:09 UTC
(In reply to vt from comment #2)
> (In reply to fujiwara from comment #1)
> > You can hide the GUI with ibus-setup -> "Do not show" in Show property panel
> > if the GUI is the part of Property Panel.
> 
> I didn't see "Do not show" option, 

I think you can find "Show property panel" in "General" tab.

Comment 4 vt 2017-12-06 07:29:43 UTC
(In reply to fujiwara from comment #3)
> 
> I think you can find "Show property panel" in "General" tab.

You're right, the windows doesn't show after hide the property panel.

Comment 5 fujiwara 2017-12-06 08:03:40 UTC
Not sure why your property panel shows a wrong size.

But the original issue is that ibus-ui-gtk3 should not be launched in GNOME desktop.

I think you can check with `ps -ef` command if ibus-daemon is launched by imsettings .

If ibus-daemon is launched by gnome-shell, it should be `ibus-daemon --panel disable` .

I"d ask imsettings why imsettings launch ibus-daemon in GNOME desktop.

Comment 6 Akira TAGOH 2017-12-06 10:45:21 UTC
because gnome-settings-daemon doesn't have org.gnome.settings-daemon.plugins.keyboard schema anymore (ref: https://bugzilla.gnome.org/show_bug.cgi?id=772370). thus imsettings can't detect if GNOME is responsible to manage IM or not.

dunno if it is still possible or simply give up to do that and disable it completely on GNOME at all.

Comment 7 fujiwara 2017-12-07 03:35:44 UTC
I guess imsettings detects active in org.gnome.settings-daemon.plugins.keyboard .
How about checking the existence of /etc/xdg/autostart/org.gnome.SettingsDaemon.Keyboard.desktop ?

Comment 8 Akira TAGOH 2017-12-07 05:26:05 UTC
aha, so removing that file or something like that would behaves like settings false to org.gnome.settings-daemon.plugins.keyboard.active in the past release?

Comment 9 fujiwara 2017-12-07 07:24:54 UTC
I think so. My understanding is the plugin library is changed to gsd-keyboard.

Comment 10 Fedora Update System 2017-12-07 12:33:16 UTC
imsettings-1.7.3-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-587973f9c1

Comment 11 Fedora Update System 2017-12-07 12:33:25 UTC
imsettings-1.7.3-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-9a9df7cb61

Comment 12 Fedora Update System 2017-12-09 07:28:02 UTC
imsettings-1.7.3-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-587973f9c1

Comment 13 Fedora Update System 2017-12-10 00:32:16 UTC
imsettings-1.7.3-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-9a9df7cb61

Comment 14 Fedora Update System 2017-12-19 19:47:02 UTC
imsettings-1.7.3-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2017-12-19 21:34:39 UTC
imsettings-1.7.3-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Akira TAGOH 2017-12-27 02:52:20 UTC
*** Bug 1528892 has been marked as a duplicate of this bug. ***

Comment 17 Robin Lee 2017-12-27 03:56:55 UTC
*** Bug 1528892 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.