Bug 1520467
| Summary: | CephPools can't be used to override properties of the standard OpenStack pools when using ceph-ansible | ||
|---|---|---|---|
| Product: | Red Hat OpenStack | Reporter: | Giulio Fidente <gfidente> |
| Component: | openstack-tripleo-heat-templates | Assignee: | Giulio Fidente <gfidente> |
| Status: | CLOSED ERRATA | QA Contact: | Yogev Rabl <yrabl> |
| Severity: | high | Docs Contact: | |
| Priority: | high | ||
| Version: | 12.0 (Pike) | CC: | abishop, gfidente, johfulto, mariel, mburns, rhel-osp-director-maint |
| Target Milestone: | z1 | Keywords: | Triaged, ZStream |
| Target Release: | 12.0 (Pike) | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | openstack-tripleo-heat-templates-7.0.3-20.el7ost | Doc Type: | If docs needed, set a value |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2018-01-30 21:24:32 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | 1516389 | ||
| Bug Blocks: | |||
|
Description
Giulio Fidente
2017-12-04 14:18:40 UTC
Build openstack-tripleo-heat-templates-7.0.3-20.el7ost includes a patch from this bug, please update BZ state accordingly the validation failed with the error: fatal: [192.168.24.21]: FAILED! => {"failed": true, "msg": "The task includes an option with an undefined variable. The error was: 'dict object' has no attribute 'rule_name'\n\nThe error appears to have been in '/usr/share/ceph-ansible/roles/ceph-mon/tasks/openstack_config.yml': line 2, column 3, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n---\n- name: create openstack pool(s)\n ^ here\n\nexception type: <class 'ansible.errors.AnsibleUndefinedVariable'>\nexception: 'dict object' has no attribute 'rule_name'"}
with the values of the pools passes by mistral as a JSON:
{u'size': 3, u'pg_num': 64, u'name': u'volumes', u'pgp_num': 64}
and are set in the environment file accordingly:
CephPools:
[{"name":"volumes", "size": 3, "pg_num": 64, "pgp_num": 64}]
Yogev, I think you have a syntax issue. The CephPools syntax has to match ceph-ansible's rules for defining a pool. I don't recall the full syntax, but I think you need to drop the "pgp_num" part. Yogev, indeed you can't use pgp_num key. Needs to be retested, moving back ON_QA. (In reply to Giulio Fidente from comment #10) > Yogev, indeed you can't use pgp_num key. Needs to be retested, moving back > ON_QA. I have followed the official documentation: https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/12/html/deploying_an_overcloud_with_containerized_red_hat_ceph/configuring_ceph_storage_cluster_settings#custom-ceph-pools It stats that pgp_num is valid (In reply to Yogev Rabl from comment #11) > (In reply to Giulio Fidente from comment #10) > > Yogev, indeed you can't use pgp_num key. Needs to be retested, moving back > > ON_QA. > > I have followed the official documentation: > https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/12/ > html/deploying_an_overcloud_with_containerized_red_hat_ceph/ > configuring_ceph_storage_cluster_settings#custom-ceph-pools > > It stats that pgp_num is valid Yeah and that's a bug in the documentation, see [1]. We'll need to reverify this without pgp_num :( 1. https://bugzilla.redhat.com/show_bug.cgi?id=1533111 Verified with the configuration:
CephPools:
[{"name": "volumes", "size": 3, "pg_num": 128, "rule_name": ""}]
Please notice that rule_name is not mentioned in documentation
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHBA-2018:0253 |