Bug 152077 - ICE compiling wine
ICE compiling wine
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-24 13:33 EST by Todd Mokros
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.0.0-0.39
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-04 07:47:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessed source file resulting in ICE (423.00 KB, text/plain)
2005-03-24 13:33 EST, Todd Mokros
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 20635 None None None Never

  None (edit)
Description Todd Mokros 2005-03-24 13:33:24 EST
Description of problem:
while compiling wine(current cvs) with gcc-4.0.0-0.35, I ran into the following ICE:

 gcc -c -I. -I. -I../../include -I../../include  -D__WINESRC__   -D_REENTRANT
-fPIC -Wall -pipe -mpreferred-stack-boundary=2 -fno-strict-aliasing
-Wpointer-arith  -O2 -Wall -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -m32 -march=i386
-mtune=pentium4 -o profile.o profile.c
profile.c: In function 'OpenColorProfileW':
profile.c:839: internal compiler error: in cgraph_mark_reachable_node, at
cgraph.c:477
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
{standard input}: Assembler messages:
{standard input}:2231: Warning: partial line at end of file ignored
Preprocessed source stored into /tmp/ccwmUUyZ.out file, please attach this to
your bugreport.

The preprocessed source file should be attached.

Version-Release number of selected component (if applicable):
gcc-4.0.0-0.35

How reproducible:
everytime

Steps to Reproduce:
1. compiling current wine cvs, error occurs on dlls/mscms/profile.c
2.
3.
  
Actual results:


Expected results:


Additional info:
I saw that gcc-4.0.0-0.36 was in fedora core cvs, so I'm currently having a go
at building it.  I'll update the bug if it changes anything.
Comment 1 Todd Mokros 2005-03-24 13:33:25 EST
Created attachment 112324 [details]
preprocessed source file resulting in ICE
Comment 2 Anton Guda 2005-03-31 09:37:47 EST
It seems to be the same or similar error while build dvgrab-1.7-3: 
 
if g++ -DHAVE_CONFIG_H -I. -I. -I.    -D_REENTRANT -D_FILE_OFFSET_BITS=64 -O2 
-g -pipe -Wp,-D_FORTIFY_SOURCE=2 -m32 -march=i586 -mtune=pentium2 -MT dvgrab.o 
-MD -MP -MF ".deps/dvgrab.Tpo" -c -o dvgrab.o dvgrab.cc; \ 
then mv -f ".deps/dvgrab.Tpo" ".deps/dvgrab.Po"; else rm -f 
".deps/dvgrab.Tpo"; exit 1; fi 
dvgrab.cc: In constructor 'DVgrab::DVgrab(int, char**)': 
dvgrab.cc:220: internal compiler error: in cgraph_mark_reachable_node, at 
cgraph.c:477 

Note You need to log in before you can comment on or make changes to this bug.