Bug 1520865 - Patch NetworkManager-wait-online.service to revert upstream change to Require=NetworkManager.service
Summary: Patch NetworkManager-wait-online.service to revert upstream change to Require...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.5
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Thomas Haller
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-05 10:25 UTC by Thomas Haller
Modified: 2018-04-13 06:04 UTC (History)
22 users (show)

Fixed In Version: NetworkManager-1.10.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1513613
Environment:
Last Closed: 2018-04-10 13:35:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0778 None None None 2018-04-10 13:37:11 UTC

Description Thomas Haller 2017-12-05 10:25:39 UTC
+++ This bug was initially created as a clone of Bug #1513613 +++

See the original bug for details.


Upstream and for Fedora, we fixed bug 1452866 by letting NetworkManger-wait-online.service Require=NetworkManager.service.

That allows the user to

  systemctl start network-online.target

which would pull in NetworkManager.service.

A similar change was done for systemd. The commit message summarizes the issues well: See https://github.com/systemd/systemd/commit/9db307820e6f545665fc87f255af737228b7183c



The problem is, that now if you `systemctl disable NetworkManager.service`, you also need to explicitly `systemctl disable NetworkManager-wait-online.service`. Otherwise, during boot
  - network-online.target Wants=NetworkManager-wait-online.service
  - NetworkManager-wait-online.service Requires=NetworkManager.service.

For RHEL, we should not change behavior, even if the current behavior has its own issues. Revert https://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=28b97f02f64ecf94e22c8929dfd0ba64151bd9d3

Comment 5 errata-xmlrpc 2018-04-10 13:35:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0778


Note You need to log in before you can comment on or make changes to this bug.