Bug 1520901 - Erlang 20
Summary: Erlang 20
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact:
URL:
Whiteboard: ChangeAcceptedF28, SelfContainedChange
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-05 12:36 UTC by Jan Kurik
Modified: 2018-05-02 12:05 UTC (History)
7 users (show)

Fixed In Version: erlang-20.2.3-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-02 12:05:07 UTC


Attachments (Terms of Use)

Description Jan Kurik 2017-12-05 12:36:32 UTC
This is a tracking bug for Change: Erlang 20
For more details, see: https://fedoraproject.org//wiki/Changes/Erlang_20

Update Erlang/OTP to version 20.

Comment 1 Jan Kurik 2018-02-20 14:10:17 UTC
On 2018-Feb-20, we have reached the Fedora 28 Change Checkpoint: Completion deadline (testable).

At this point, all accepted changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be enabled at Change Completion deadline as well.

Change tracking bug should be set to the MODIFIED state to indicate it achieved completeness.

Incomplete and non testable Changes will be reported to FESCo for 2018-Feb-23 meeting.

Comment 2 Fedora End Of Life 2018-02-20 15:38:18 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 28 development cycle.
Changing version to '28'.

Comment 3 Jan Kurik 2018-03-06 08:58:13 UTC
On 2018-Mar-08 we reached the "Change Checkpoint: 100% Code Complete Deadline" milestone for Fedora 28 release. At this point all the Changes not at least in "ON_QA" state should be brought to FESCo for review. Please update the state of this bug to "ON_QA" if it is already 100% completed. Please let me know in case you have any trouble with the implementation and the Change needs any help or review.

Thanks, Jan

Comment 4 Randy Barlow 2018-03-06 15:09:11 UTC
I do believe that this change is ready for QA. Peter, do you agree?

Comment 5 Zbigniew Jędrzejewski-Szmek 2018-03-08 15:01:32 UTC
In F28 container:
# dnf install couchdb ejabberd elixir mochiweb rabbitmq-server wings erlang-basho_metrics erlang-bitcask erlang-cache_tab erlang-cl erlang-ebloom erlang-eleveldb erlang-emmap erlang-esip erlang-fast_tls erlang-fast_xml erlang-fast_yaml erlang-hyper erlang-iconv erlang-jiffy erlang-riak_ensemble erlang-sd_notify erlang-skerl erlang-snappy erlang-stringprep erlang-xmpp
Last metadata expiration check: 0:59:03 ago on Thu Mar  8 14:59:27 2018.
Error: 
 Problem 1: conflicting requests
  - nothing provides erlang(erl_nif_version) = 2.11 needed by couchdb-1.7.1-5.fc28.x86_64
 Problem 2: conflicting requests
  - nothing provides erlang(erl_nif_version) = 2.11 needed by erlang-bitcask-2.0.8-3.fc27.x86_64
 Problem 3: conflicting requests
  - nothing provides erlang(erl_nif_version) = 2.11 needed by erlang-cl-1.2.1-16.fc27.x86_64
 Problem 4: conflicting requests
  - nothing provides erlang(erl_nif_version) = 2.11 needed by erlang-eleveldb-1:2.0.34-5.fc28.x86_64
 Problem 5: conflicting requests
  - nothing provides erlang(erl_nif_version) = 2.11 needed by erlang-hyper-0-0.1.20161011git4b1abc4.fc28.x86_64
 Problem 6: conflicting requests
  - nothing provides erlang(erl_nif_version) = 2.11 needed by erlang-riak_ensemble-2.1.8-2.fc28.x86_64
 Problem 7: package wings-2.1.5-2.fc28.x86_64 requires erlang-cl(x86-64), but none of the providers can be installed
  - conflicting requests
  - nothing provides erlang(erl_nif_version) = 2.11 needed by erlang-cl-1.2.1-16.fc27.x86_64

That's not good. Either those packages need to be rebuilt, or the whole change needs to be reverted.

Comment 6 Peter Lemenkov 2018-03-08 15:20:23 UTC
(In reply to Zbigniew Jędrzejewski-Szmek from comment #5)

Almost all these packages were rebuilt already (and pushed to F28 batched). All except couchdb (which has faulty test which triggers timeout often, and unrelated to that change) and erlang-hyper which also has faulty test. I'll handle both soon.

I do believe this feature/change is testable. So going to move it to ON_QA.

Comment 7 Randy Barlow 2018-03-08 16:00:00 UTC
I rebuild the ejabberd stack a few weeks ago so it should install (and work too!)

Comment 8 Randy Barlow 2018-03-08 16:00:19 UTC
Ugh, *rebuilt...

Comment 9 Zbigniew Jędrzejewski-Szmek 2018-03-08 16:01:52 UTC
ejabberd was not listed by dnf as uninstallable, I don't think there's any issue.

Comment 10 Zbigniew Jędrzejewski-Szmek 2018-03-08 16:02:21 UTC
Unsetting NEEDINFO since the change is ON_QA now.


Note You need to log in before you can comment on or make changes to this bug.