Bug 1520922 - Review Request: extractpdfmark - Extract page mode and named destinations as PDFmark from PDF
Summary: Review Request: extractpdfmark - Extract page mode and named destinations as ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: William Moreno
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-05 13:09 UTC by Federico Bruni
Modified: 2018-07-03 17:55 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-03 17:55:36 UTC
williamjmorenor: fedora-review+


Attachments (Terms of Use)

Description Federico Bruni 2017-12-05 13:09:58 UTC
Spec URL: https://pagure.io/rpm-extractpdfmark/blob/master/f/extractpdfmark.spec
SRPM URL: https://copr.fedorainfracloud.org/coprs/fedelibre/extractpdfmark/
Description: Extract page mode and named destinations as PDFmark from PDF
Fedora Account System Username: fedelibre

It's my first Fedora package, so I need a sponsor.

This package is recommended to build another Fedora package, lilypond. It's not a requirement, but the configure will print a warning if extractpdfmark is missing.
extractpdfmark was created to reduce substantially the size of LilyPond manuals PDFs, as it removes duplicate embedded font subsets.

The %description is probably too long. I did a copy&paste from upstream README.
I can cut it down if needed.

Thanks for reviewing

Comment 1 William Moreno 2017-12-16 04:19:27 UTC
Hello and thanks for the interest to help with Fedora packaging.

Quick check of previus steps to become a packager:

Are suscrived at less to the devel-announce and packaging mainling list?
Do you have a proper profile in the Fedora Wiki?
A self introduction to devel is always nice to see.

Comment 2 Federico Bruni 2017-12-20 23:12:32 UTC
I had already subscribed to devel-announce.
I'm now subscribed to packaging as well.

A proper profile to describe who I am? I cannot log in to the wiki at the moment. It seems a problem with cookies. I've tried to clear them but didn't help.

Should I introduce myself (my contributions to Free Software) here?
In a nutshell, my main contributions have been:

- translations english>italian for LilyPond project and a few GNOME projects such as Geary and Boxes
- user support on several mailing lists
- bug triaging for LilyPond and recently for Geary
- building custom Linux images (see LilyDev and LilyDevOS in Github)

I've been using Fedora since a couple of years, after some years of Debian.
I'm interested in learning more how RPM packaging works.

I've made some tries to learn programming (moved first steps in Python and Golang), but I've never had the time and the perseverance to really go on. Never say never!

Comment 4 William Moreno 2018-01-07 18:52:58 UTC
Hello

Advancing with this review in fedora we do not need:

rm -rf %{buildroot}

And the changelog is missing the - %{version}.%{release} information.

Comment 5 Omar Berroteran 2018-01-07 20:22:35 UTC
Package Review
==============
Must check owned files properties, there are many conflicts. 

===== MUST items =====

Generic:
[X]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[X]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "MIT/X11 (BSD like)", "FSF All Permissive", "GPL (v3 or
     later)", "Unknown or generated". 79 files have unknown license.
     Detailed output of licensecheck in
     /home/lkf/1520922-extractpdfmark/licensecheck.txt
[X]: License file installed when any subpackage combination is installed.
[!]: Package does not own files or directories owned by other packages.
     Note: Dirs in package are owned also by: /usr/lib/.build-id(iputils,
     efivar-libs, gd, gc, libtomcrypt, gdbm, gpgme, rpm-plugin-selinux,
     python3-sqlalchemy, libmcpp, libnfsidmap, libimagequant, lua-libs,
     trousers, bzip2-libs, unzip, libdb-utils, xorg-x11-font-utils, gtk2,
     gtk3, OpenEXR-libs, libcom_err, pycryptopp, libseccomp, gnutls, npth,
     p11-kit, libyaml, iptables-libs, rpm-build, cryptsetup-libs, ykpers,
     libmodman, libselinux-utils, perl-Scalar-List-Utils, parted, zstd,
     mozjs17, mesa-libwayland-egl, ghostscript-x11, lua-posix, libwebp,
     libxslt, libpkgconf, libunistring, keyutils-libs, perl-Encode,
     elfutils, python2-cryptography, libgpg-error, perl-Digest-SHA, audit-
     libs-python3, nss-tools, perl-Data-Dumper, gawk, python2-rpm,
     libbasicobjects, c-ares, lua-lpeg, python2-cairo, python3-crypto,
     jansson, e2fsprogs-libs, libdwarf, librsvg2, lcms2, apr,
     libsss_nss_idmap, annobin, deltarpm, file-libs, grub2-tools, libxcb,
     trousers-lib, libyubikey, python3-pycurl, mokutil, zip,
     python3-gobject, m4, gdb-headless, vim-enhanced, libusbx,
     python3-psutil, compat-openssl10, qrencode-libs, libICE, drpm, libwmf-
     lite, createrepo_c-libs, libtasn1, python3-coverage, openssh, sqlite,
     http-parser, tar, diffstat, sudo, freetype, openssl, dhcp-client,
     libarchive, gcc, systemd-bootchart, dwz, python2-gobject, avahi-libs,
     pyliblzma, ncurses-libs, polkit, pigz, checkpolicy, libpsl,
     python2-tornado, python3-rpm, libini_config, openssh-clients, libuser,
     python3-tornado, perl-libs, libX11, systemtap-devel, kbd, graphviz,
     htop, boost-date-time, python3-cryptography, systemd, libacl, gts,
     libwayland-cursor, libnl3, libsecret, libSM, policycoreutils, pixman,
     libidn, libXxf86misc, grubby, libatomic_ops, python2-kerberos, pango,
     libss, libbabeltrace, systemtap-client, libpath_utils, dbus, polkit-
     libs, python3-systemd, perl-threads, perl-Params-Validate,
     libsss_certmap, python2-libcomps, rpm-plugin-systemd-inhibit, cairo,
     audit-libs, nss-sysinit, libgcc, ilmbase, gettext-libs, p11-kit-trust,
     libref_array, python2-krbv, python3-cffi, libstemmer, dbus-libs,
     syslinux-extlinux, cairo-gobject, fftw-libs-double, at-spi2-core,
     usermode, bash, glibc-common, linux-atm-libs, libedit, libidn2,
     enchant, libuuid, subversion-libs, atk, python3-cairo, openldap, isl,
     ImageMagick, harfbuzz, xz, libXcomposite, mtools, gtk-update-icon-
     cache, vim-minimal, python3-wrapt, pcre-cpp, python2-libs,
     python3-markupsafe, libcrypt, groff-base, libdatrie, python3-lazy-
     object-proxy, gdk-pixbuf2, dhcp-libs, python2-cccolutils, libtalloc,
     libldb, grep, guile, pcre-utf16, libepoxy, cronie-anacron, libserf,
     xfsprogs, man-db, libcroco, libgcrypt, grub2-tools-efi, ipcalc,
     libart_lgpl, dconf, xz-libs, dbus-glib, timedatex, perl-Package-Stash-
     XS, colord-libs, which, boost-chrono, libcap, sssd-nfs-idmap, libdb,
     passwd, libgcab1, python3-bcrypt, desktop-file-utils, libXdamage,
     libsmartcols, rpm-libs, nano, libthai, createrepo_c, fakeroot,
     python2-markupsafe, libproxy, libpipeline, python2-sqlalchemy,
     iproute, python2-gpg, findutils, popt, python2-xpyb, fakeroot-libs,
     libsss_idmap, gobject-introspection, libpwquality, lua, boost-atomic,
     fontconfig, patchutils, krb5-workstation, python3-hawkey, os-prober,
     jbigkit-libs, python3-dbus, info, iproute-tc, systemd-libs, libjpeg-
     turbo, cpio, libpng, rest, lz4-libs, util-linux, libXfont, patch,
     krb5-libs, sqlite-libs, net-tools, python3-librepo, pkgconf, json-c,
     python3-libselinux, libwayland-client, sed, libipt, libsss_autofs,
     perl-threads-shared, glib-networking, kmod, initscripts, device-
     mapper, python2-librepo, libXtst, kpartx, xapian-core-libs,
     ghostscript-core, python3-pillow, sssd-client, GeoIP, hardlink,
     libcollection, libXrandr, doxygen, libsolv, libxkbcommon, perl-
     Unicode-UTF8, libzstd, nss-softokn, lasi, libXft, binutils, libattr,
     perl-Variable-Magic, gnupg2-smime, rpm, xorg-x11-server-utils,
     libssh2, syslinux, python3-libcomps, gnupg2, libXcursor, libverto,
     dracut, glib2-devel, cracklib, procps-ng, python3-lxml, ncurses,
     libdnf, python3-libs, graphite2, python3-kerberos, perl-version,
     appstream, perl-PathTools, libtdb, zlib, netpbm, libselinux,
     libassuan, python3-gpg, libxml2, expat, python3-setools, perl-
     interpreter, chkconfig, libargon2, libcurl, make, hostname, coreutils,
     libcap-ng, libsoup, pam, libgomp, python2-cffi, pinentry, fuse-sshfs,
     fuse, perl-Net-SSLeay, perl-Filter, librepo, lua-filesystem, audit,
     cups-libs, libappstream-glib, python2-coverage, gdk-pixbuf2-modules,
     at-spi2-atk, libsepol, gzip, libtevent, nss-pem, vim-common, lzo,
     less, libfdisk, tcl, rpm-build-libs, libnghttp2, python2-lxml,
     openssl-libs, gobject-introspection-devel, boost-system, libpcap,
     subversion, docker-rhel-push-plugin, systemtap-runtime, gmp, perl-
     Unicode-Normalize, perl-Socket, apr-util, polkit-pkla-compat, pcre2,
     python3, python2, cyrus-sasl-lib, gpm-libs, nspr, fuse-libs, python3
     -gobject-base, perl-TermReadKey, libpng-devel, python3-PyYAML,
     libXfixes, shared-mime-info, libblkid, libsigsegv, json-glib,
     libsss_sudo, libfontenc, boost-thread, rsync, sssd-common, glibc,
     btrfs-progs, shadow-utils, perl-IO, bind99-libs, libcgroup, perl-
     Params-Util, libXaw, libXau, fipscheck, libXinerama, wget, kmod-libs,
     libtommath, elfutils-libs, perl-MIME-Base64, acl, libmount, libkadm5,
     libgusb, glib2, libtiff, ImageMagick-libs, python3-libsemanage,
     libstdc++, libtool-ltdl, libmnl, nss, libXxf86vm, pcre, git, cronie,
     ima-evm-utils, tcp_wrappers-libs, systemd-pam, git-core, python2
     -gobject-base, perl-Storable, perl-Digest-MD5, grub2-tools-extra,
     libmpc, openssh-server, libXi, dyninst, openjpeg2, libXt, libXext,
     mcpp, python2-hawkey, perl-Sort-Key, nss-util, hunspell, libsemanage,
     libXrender, systemd-container, libcomps, systemd-udev, file, curl,
     nettle, bzip2, python2-pillow, libXmu, gettext, elfutils-libelf, nss-
     softokn-freebl, fipscheck-lib, jasper-libs, python2-pycurl,
     libutempter, device-mapper-libs, libmetalink, libffi, readline, pcre-
     utf32, ustr, diffutils, cryptopp, e2fsprogs, chrony, grub2-tools-
     minimal, libdhash, cpp, libXpm, libksba, hello, mpfr), /usr/lib
     /.build-id/13(systemd, p11-kit-trust, perl-interpreter, nspr,
     ImageMagick-libs, btrfs-progs, perl-Params-Validate, libxcb, util-
     linux, rpm)
[!]: %build honors applicable compiler flags or justifies otherwise.
[!]: Package contains no bundled libraries without FPC exception.
[!]: Changelog in prescribed format.
[!]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
     Note: rm -rf %{buildroot} present but not required
[X]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[X]: Package uses nothing in %doc for runtime.
[X]: Package consistently uses macros (instead of hard-coded directory
     names).
[X]: Package is named according to the Package Naming Guidelines.
[X]: Package does not generate any conflict.
[X]: Package obeys FHS, except libexecdir and /usr/target.
[X]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[X]: Requires correct, justified where necessary.
[X]: Spec file is legible and written in American English.
[X]: Package contains systemd file(s) if in need.
[X]: Useful -debuginfo package or justification otherwise.
[X]: Package is not known to require an ExcludeArch tag.
[X]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 51200 bytes in 3 files.
[!]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on debuginfo package(s).
     Note: There are rpmlint messages (see attachment).
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.
[x]: Package should not use obsolete m4 macros
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: extractpdfmark-1.0.2-1.fc28.x86_64.rpm
          extractpdfmark-debuginfo-1.0.2-1.fc28.x86_64.rpm
          extractpdfmark-debugsource-1.0.2-1.fc28.x86_64.rpm
          extractpdfmark-1.0.2-1.fc28.src.rpm
extractpdfmark.x86_64: W: no-version-in-last-changelog
extractpdfmark.x86_64: W: only-non-binary-in-usr-lib
extractpdfmark-debuginfo.x86_64: W: no-version-in-last-changelog
extractpdfmark-debugsource.x86_64: W: no-version-in-last-changelog
extractpdfmark-debugsource.x86_64: W: no-documentation
extractpdfmark.src: W: no-version-in-last-changelog
4 packages and 0 specfiles checked; 0 errors, 6 warnings.




Rpmlint (debuginfo)
-------------------
Checking: extractpdfmark-debuginfo-1.0.2-1.fc28.x86_64.rpm
extractpdfmark-debuginfo.x86_64: W: no-version-in-last-changelog
1 packages and 0 specfiles checked; 0 errors, 1 warnings.





Rpmlint (installed packages)
----------------------------
sh: /usr/bin/python: No such file or directory
extractpdfmark.x86_64: W: no-version-in-last-changelog
extractpdfmark.x86_64: W: invalid-url URL: https://github.com/trueroad/extractpdfmark/ <urlopen error [Errno -2] Name or service not known>
extractpdfmark.x86_64: W: only-non-binary-in-usr-lib
extractpdfmark-debuginfo.x86_64: W: no-version-in-last-changelog
extractpdfmark-debuginfo.x86_64: W: invalid-url URL: https://github.com/trueroad/extractpdfmark/ <urlopen error [Errno -2] Name or service not known>
extractpdfmark-debugsource.x86_64: W: no-version-in-last-changelog
extractpdfmark-debugsource.x86_64: W: invalid-url URL: https://github.com/trueroad/extractpdfmark/ <urlopen error [Errno -2] Name or service not known>
extractpdfmark-debugsource.x86_64: W: no-documentation
3 packages and 0 specfiles checked; 0 errors, 8 warnings.



Requires
--------
extractpdfmark (rpmlib, GLIBC filtered):
    libc.so.6()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libm.so.6()(64bit)
    libpoppler.so.72()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    libstdc++.so.6(CXXABI_1.3.9)(64bit)
    rtld(GNU_HASH)

extractpdfmark-debuginfo (rpmlib, GLIBC filtered):

extractpdfmark-debugsource (rpmlib, GLIBC filtered):



Provides
--------
extractpdfmark:
    extractpdfmark
    extractpdfmark(x86-64)

extractpdfmark-debuginfo:
    debuginfo(build-id)
    extractpdfmark-debuginfo
    extractpdfmark-debuginfo(x86-64)

extractpdfmark-debugsource:
    extractpdfmark-debugsource
    extractpdfmark-debugsource(x86-64)



Source checksums
----------------
https://github.com/trueroad/extractpdfmark/releases/download/v1.0.2/extractpdfmark-1.0.2.tar.gz :
  CHECKSUM(SHA256) this package     : 63f3ababd5b1081ef92ff7a417597302327c1db3902cdb9827fade147558e6db
  CHECKSUM(SHA256) upstream package : 63f3ababd5b1081ef92ff7a417597302327c1db3902cdb9827fade147558e6db

Comment 6 Federico Bruni 2018-01-17 07:24:06 UTC
(In reply to William Moreno from comment #4)
> Hello
> 
> Advancing with this review in fedora we do not need:
> 
> rm -rf %{buildroot}
> 
> And the changelog is missing the - %{version}.%{release} information.

Thanks William, I've made the changes requested, pushed to Pagure repo and made a new build here:
https://copr.fedorainfracloud.org/coprs/fedelibre/extractpdfmark/build/702296/

I'll check Omar's review in the next days

Comment 7 Igor Gnatenko 2018-01-25 07:03:08 UTC
> [!]: %build honors applicable compiler flags or justifies otherwise.
I don't see why, according to build.log it is fine.

> [!]: Package contains no bundled libraries without FPC exception.
There are no bundled libs as I can see.

Comment 8 marcindulak 2018-02-03 11:22:56 UTC
About the problem with duplicate COPYING: a simple rm will be easier to maintain, moreover COPYING is not the only packaging problem, try to rpmbuild for EPEL7.

If you prefer to maintain a patch then look how other distributions solved the problem - Debian already uses such patch:
https://sources.debian.org/patches/extractpdfmark/1.0.2-1/0002-Exclude-some-docs-from-install.patch/

%install
%make_install
rm -f %{buildroot}%{_docdir}/%{name}/COPYING
mv %{buildroot}%{_docdir}/%{name} %{buildroot}%{_pkgdocdir}

Comment 9 Björn Persson 2018-02-03 17:29:38 UTC
(In reply to marcindulak from comment #8)
> mv %{buildroot}%{_docdir}/%{name} %{buildroot}%{_pkgdocdir}

Where those aren't equal, the correct solution is to pass "--docdir=%{_pkgdocdir}" to configure. That should work as Autoconf is used.

Comment 10 marcindulak 2018-02-03 18:40:40 UTC
(In reply to Björn Persson from comment #9)
> (In reply to marcindulak from comment #8)
> > mv %{buildroot}%{_docdir}/%{name} %{buildroot}%{_pkgdocdir}
> 
> Where those aren't equal, the correct solution is to pass
> "--docdir=%{_pkgdocdir}" to configure. That should work as Autoconf is used.

As:

%configure --docdir=%{_pkgdocdir}

and not as

./configure --docdir=%{_pkgdocdir}

as I've tried initially.

Comment 11 William Moreno 2018-02-04 02:59:32 UTC
(In reply to Federico Bruni from comment #6)
> (In reply to William Moreno from comment #4)
> > Hello
> > 
> > Advancing with this review in fedora we do not need:
> > 
> > rm -rf %{buildroot}
> > 
> > And the changelog is missing the - %{version}.%{release} information.
> 
> Thanks William, I've made the changes requested, pushed to Pagure repo and
> made a new build here:
> https://copr.fedorainfracloud.org/coprs/fedelibre/extractpdfmark/build/
> 702296/
> 
> I'll check Omar's review in the next days

Hello Federico I have seen a real interest in you to become a packager, please post the last version of your spec file and source rpm.

Comment 12 Federico Bruni 2018-02-05 13:10:07 UTC
Hello William

I've made a new build in Copr:
https://copr.fedorainfracloud.org/coprs/fedelibre/extractpdfmark/build/709990/

I think I will do a new release (1.0.2-2) as soon as this request passes the review.

Comment 14 William Moreno 2018-02-12 03:18:24 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
- All build dependencies are listed in BuildRequires, except for any that
  are listed in the exceptions section of Packaging Guidelines.
  Note: These BR are not needed: gcc-c++
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#Exceptions_2

Is common in fedora spec to split requires and build requires in a line per package, this make simple to know when a dependency is added or dropped loking at the diff of a commit.

===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
[x]: License file installed when any subpackage combination is installed.
[x]: Package does not own files or directories owned by other packages.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[x]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 20480 bytes in 2 files.
[!]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Fully versioned dependency in subpackages if applicable.
[-]: Package functions as described.
[-]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on debuginfo package(s).
[x]: Rpmlint is run on all installed packages.
[x]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.
[x]: Package should not use obsolete m4 macros
[x]: Spec file according to URL is the same as in SRPM.


Requires
--------
extractpdfmark (rpmlib, GLIBC filtered):
    libc.so.6()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libm.so.6()(64bit)
    libpoppler.so.72()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    libstdc++.so.6(CXXABI_1.3.9)(64bit)
    rtld(GNU_HASH)

extractpdfmark-debuginfo (rpmlib, GLIBC filtered):

extractpdfmark-debugsource (rpmlib, GLIBC filtered):

Provides
--------
extractpdfmark:
    extractpdfmark
    extractpdfmark(x86-64)

extractpdfmark-debuginfo:
    debuginfo(build-id)
    extractpdfmark-debuginfo
    extractpdfmark-debuginfo(x86-64)

extractpdfmark-debugsource:
    extractpdfmark-debugsource
    extractpdfmark-debugsource(x86-64)

Source checksums
----------------
https://github.com/trueroad/extractpdfmark/releases/download/v1.0.2/extractpdfmark-1.0.2.tar.gz :
  CHECKSUM(SHA256) this package     : 63f3ababd5b1081ef92ff7a417597302327c1db3902cdb9827fade147558e6db
  CHECKSUM(SHA256) upstream package : 63f3ababd5b1081ef92ff7a417597302327c1db3902cdb9827fade147558e6db

Comment 15 William Moreno 2018-02-17 03:36:30 UTC
ping

Comment 16 Federico Bruni 2018-02-19 09:22:18 UTC
Sorry for the delay, I was away for a business trip.

I've just committed these changes to the spec file:

```
$ git diff
diff --git a/extractpdfmark.spec b/extractpdfmark.spec
index a5d8f42..d75197c 100644
--- a/extractpdfmark.spec
+++ b/extractpdfmark.spec
@@ -7,7 +7,9 @@ License:        GPLv3+
 URL:            https://github.com/trueroad/extractpdfmark/
 Source0:        https://github.com/trueroad/extractpdfmark/releases/download/v%{version}/%{name}-%{version}.tar.gz
 
-BuildRequires:  automake gettext-devel poppler-devel gcc-c++
+BuildRequires:  automake
+BuildRequires:  gettext-devel
+BuildRequires:  poppler-devel
 
 %description
 When you create a PDF document using something like a TeX system you may include
```

Comment 17 William Moreno 2018-02-19 22:31:18 UTC
Please post the updated spec and src.rpm in the form:

Spec URL: 
SRPM URL:

Also note that as per this F29 change [0] gcc-c++ will need to be aded to every spec that need it, but I will no request a new update os the spec, you have done a great work adressing the issues in the review and looking for help in the mailing list, also the package looks good so just update the links in the mentiones form for a final check and I think we are done with this review.

0: https://fedoraproject.org/wiki/Changes/Remove_GCC_from_BuildRoot

Comment 19 William Moreno 2018-02-21 14:03:49 UTC
I am fine with this package, and good work by the packager.

I have aproved this package and added to the packager group in FAS, congrats.

Comment 20 marcindulak 2018-02-21 14:09:24 UTC
Now, as an extra useful step try to make the spec to build on EPEL7 (see one of my comments above) and maintain the package also in EPEL7.

Comment 21 Gwyn Ciesla 2018-03-06 14:01:08 UTC
(fedrepo-req-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/extractpdfmark

Comment 22 Federico Bruni 2018-03-06 14:32:33 UTC
marcindulak, I've seen the problem when building for EPEL7. I'll try to fix it as soon as I have some spare time for it.

Comment 23 William Moreno 2018-06-26 16:25:54 UTC
(In reply to Federico Bruni from comment #18)
> Spec URL:
> https://copr-be.cloud.fedoraproject.org/results/fedelibre/extractpdfmark/
> fedora-rawhide-x86_64/00719190-extractpdfmark/extractpdfmark.spec
> 
> SRPM URL:
> https://copr-be.cloud.fedoraproject.org/results/fedelibre/extractpdfmark/
> fedora-rawhide-x86_64/00719190-extractpdfmark/extractpdfmark-1.0.2-2.fc28.
> src.rpm

Federico any update here? I do not see any build of this package yet.

Comment 24 Federico Bruni 2018-06-29 15:52:08 UTC
William, sorry for disappearing. I've been too busy lately. I'll try to work on this next week.

There was a misunderstanding, as I do not have a clear understanding of how the process goes.
In March initially I thought that I didn't have anything left to do. Then I did not see any package in F28 and I realized that something was missing.

I'll read this:
https://fedoraproject.org/wiki/Using_the_Koji_build_system

and launch the build early next week.

Comment 25 William Moreno 2018-07-01 01:09:35 UTC
If so please close this bug and paste a link to the complete build.

Comment 26 Federico Bruni 2018-07-03 17:55:36 UTC
I think I got it. Let me know if there's anything wrong.

https://koji.fedoraproject.org/koji/taskinfo?taskID=28004064

https://koji.fedoraproject.org/koji/packageinfo?packageID=26442


Note You need to log in before you can comment on or make changes to this bug.