Bug 1520988 - [RFE] VDO Should Log Volume's Operating Mode When Started
Summary: [RFE] VDO Should Log Volume's Operating Mode When Started
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kmod-kvdo
Version: 7.5
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: corwin
QA Contact: Jakub Krysl
URL:
Whiteboard:
Depends On:
Blocks: 1654309 1546181 1548459
TreeView+ depends on / blocked
 
Reported: 2017-12-05 15:19 UTC by Dennis Keefe
Modified: 2021-09-03 12:11 UTC (History)
4 users (show)

Fixed In Version: 6.1.1.88
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1548459 (view as bug list)
Environment:
Last Closed: 2018-10-30 09:38:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3094 0 None None None 2018-10-30 09:39:26 UTC

Description Dennis Keefe 2017-12-05 15:19:01 UTC
Description of problem:
When VDO a VDO volume is started the operating mode should be logged.

Version-Release number of selected component (if applicable):

How reproducible:
100%

Steps to Reproduce:
1. Create VDO volume 
2. Check logs for operating mode normal

Actual results:
Nothing about the state of VDO is logged on startup of a volume

Expected results:
VDO should log what state the volume is in 

vdo[942]: VDO instance 0 volume operating mode: {normal|recovering|read-only}


Additional info:

Comment 6 Jakub Krysl 2018-07-10 13:51:11 UTC
Tested on:
RHEL-7.6-20180626.0
kernel-3.10.0-915.el7
kmod-vdo-6.1.1.99-1.el7
vdo-6.1.1.99-2.el7

There is new line when VDO is started in /var/log/messages:
kvdo13:journalQ: VDO commencing normal operation

Comment 8 errata-xmlrpc 2018-10-30 09:38:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3094


Note You need to log in before you can comment on or make changes to this bug.