Bug 152109 - Nautilus crashes when clicking properties on mp3 file
Nautilus crashes when clicking properties on mp3 file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-24 17:08 EST by Peter Rother
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-04 10:43:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This file makes Nautilus hang (1.31 MB, audio/x-mp3)
2005-04-11 14:48 EDT, Carlos Fenollosa Bielsa
no flags Details

  None (edit)
Description Peter Rother 2005-03-24 17:08:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1

Description of problem:
Right-clicking on various of my mp3s and hitting properties will in turn crash nautilus. Running in command-line yields:

(nautilus:21502): GLib-GObject-WARNING **: gsignal.c:1716: signal `group-switch' is invalid for instance `0x9e824d0'

(nautilus:21502): GLib-GObject-WARNING **: IA__g_object_set_valist: object class `GstPlayBin' has no property named `suburi'
Segmentation fault

Version-Release number of selected component (if applicable):
nautilus-2.10.0-1

How reproducible:
Always

Steps to Reproduce:
1. Enter music folder in nautilus
2. Right-click on mp3 file
3. Hit properties 
  

Actual Results:  Nautilus immediately shutdown with no warnings.

Expected Results:  The properties dialog should have come up.

Additional info:
Comment 1 Carlos Fenollosa Bielsa 2005-04-11 14:48:52 EDT
Created attachment 112978 [details]
This file makes Nautilus hang

Right click on the file and click on "preferences". Nautilus hangs.

If it doesn't, try again. For me, it hangs 80%, and shows properties 20% the
times
Comment 2 Joe Reid 2005-04-17 20:06:58 EDT
I'm getting the same in FC4Test2, nautilus-2.10.0-3.
Comment 3 Pavlos Gerardos 2005-08-15 09:03:15 EDT
I'm also facing the same problem in FC4 after upgrading from FC3.
99% of the mp3 files cause nautilus to crash. I've only found one mp3 which can
be right-clicked with no problems, yet i've not been able to find any
differences from the rest (same permissions, same folder, etc).
The problem happens always in my case. I've tried moving files to different
directories just for testing purposes.
This did not help either...
Comment 4 Alexander Larsson 2006-09-04 10:43:26 EDT
This looks like a totem-properties-page bug.
I don't see it in rawhide.

Note You need to log in before you can comment on or make changes to this bug.