Bug 152111 - libbind.la screws up compiling other packages
libbind.la screws up compiling other packages
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-24 17:39 EST by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-28 09:30:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-03-24 17:39:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Description of problem:
When compiling the openldap from SRPMS, libtool fails attempting to link with /usr/lib/libbind.a since no FC3 package provide any such file.  Problem was resolved by removing from /usr/lib/libbind.la the following line:
old_library='libbind.a'

Version-Release number of selected component (if applicable):
bind-libs-9.2.5-1

How reproducible:
Always

Steps to Reproduce:
1.Install FC3
2.Install src.rpm of openldap
3.Run rpmbuild
  

Actual Results:  libtool fails to link with /usr/lib/libbind.a

Expected Results:  Either libbind.a should be provided as part of bind-libs or the libbind.la should not have a reference to it (such that libtool does a shared link)

Additional info:
Comment 1 Jason Vas Dias 2005-03-24 17:54:10 EST
The bind-libbind package DOES provide /usr/lib/libbind.a . 

If it is not there, it was somehow removed from your system and
reinstalling the package should correct this.

But openldap should be compiled to use libresolv.a instead of libbind -
the openldap configure script incorrectly picks up libbind instead of
libresolv. 

This openldap problem has been fixed with openldap-2.2.23-4, in FC4 -
downloading this src.rpm and building it or just removing the optional
bind-libbind package should fix your problem.

Note You need to log in before you can comment on or make changes to this bug.