Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1521159

Summary: [free-stg] all pods are encountering sandbox creation issues
Product: OpenShift Container Platform Reporter: Justin Pierce <jupierce>
Component: NetworkingAssignee: Ben Bennett <bbennett>
Status: CLOSED DUPLICATE QA Contact: Meng Bo <bmeng>
Severity: high Docs Contact:
Priority: unspecified    
Version: 3.7.0CC: aos-bugs, eparis, jchevret, jupierce
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-12-08 20:46:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Justin Pierce 2017-12-05 21:44:00 UTC
Description of problem:
The free-stg cluster is experiencing extremely frequent sandbox creation issues. 

Version-Release number of selected component (if applicable):
v3.7.9

How reproducible:
Near 100%

Steps to Reproduce:
1. Create a pod
2. The pod is scheduled but has reoccurring sandbox create errors


Additional Info: 
Example events:
4:41:00 PM	Normal	Sandbox Changed 	Pod sandbox changed, it will be killed and re-created.
89 times in the last 36 minutes
4:26:16 PM	Warning	Failed Create Pod Sand Box 	Failed create pod sandbox.
54 times in the last 37 minutes
4:05:58 PM	Normal	Successful Mount Volume 	MountVolume.SetUp succeeded for volume "default-token-zhld2"
4:05:56 PM	Normal	Scheduled 	Successfully assigned busybox to ip-172-31-71-195.us-east-2.compute.internal

Comment 1 Justin Pierce 2017-12-05 21:51:25 UTC
Logs from masters & busybox pod node: http://file.rdu.redhat.com/~jupierce/share/free-stg-sandbox.tgz

Comment 2 Ben Bennett 2017-12-08 20:45:32 UTC
The logs have:

Dec 05 21:46:42 ip-172-31-71-195.us-east-2.compute.internal atomic-openshift-node[2150]: E1205 21:46:42.954478    2150 cni.go:294] Error adding network: CNI request failed with status 400: 'failed to run IPAM for c138e6d686957756fd4c4a2b850b1434d58e94fd9ce2fe1ec1112e99db1a6d68: failed to run CNI IPAM ADD: no IP addresses available in network: openshift-sdn

Comment 3 Ben Bennett 2017-12-08 20:46:14 UTC

*** This bug has been marked as a duplicate of bug 1518912 ***