Bug 1521190 - ThunderX: IPv6 TX failure unless checksum offload disabled
Summary: ThunderX: IPv6 TX failure unless checksum offload disabled
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2017-12-05 23:56 UTC by Jeremy Linton
Modified: 2018-02-22 12:49 UTC (History)
21 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-02-22 12:49:35 UTC


Attachments (Terms of Use)

Description Jeremy Linton 2017-12-05 23:56:21 UTC
Description of problem: IPV6 on the thunderX has incorrect checksum calculations.

This is a clone of Ubuntu bug: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1736593

It has an upstream fix to disable checksum offload for ipv6 packets here:

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/drivers/net/ethernet/cavium/thunder/nicvf_queues.c?id=fa6d7cb5d76cf0467c61420fc9238045aedfd379


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Laura Abbott 2018-02-20 20:06:54 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  As kernel maintainers, we try to keep up with bugzilla but due the rate at which the upstream kernel project moves, bugs may be fixed without any indication to us. Due to this, we are doing a mass bug update across all of the Fedora 27 kernel bugs.
 
Fedora 27 has now been rebased to 4.15.3-300.f27.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you experience different issues, please open a new bug report for those.

Comment 2 Jeremy Linton 2018-02-21 21:09:18 UTC
This went into 4.15-rc3 under commit 134059fd2775b (which varies from the linked email).

Clearing needinfo/marking for QA...

Comment 3 Justin M. Forbes 2018-02-22 12:49:35 UTC
Thanks for the update, will close this as current release as 4.15 is live now.


Note You need to log in before you can comment on or make changes to this bug.