Bug 15213 - IO Port conflict of soundcard after upgrade
Summary: IO Port conflict of soundcard after upgrade
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alan Cox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-03 08:50 UTC by Dave Peacock
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-07 16:31:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch has been added to our current source tree to fix this problem. (524 bytes, patch)
2000-08-07 16:31 UTC, Michael K. Johnson
no flags Details | Diff

Description Dave Peacock 2000-08-03 08:50:15 UTC
HI,
Not sure if "kernel" is the correct category,  but it is related to the
sound card driver.

After doing an "upgrade" install of pinstripe, my soundcard fails to
initialise.
I get IO Port conflicts, and dmesg says the usual about port 0xYYY in use
etc,
there are no special messages.

My soundcard is an Ensoniq AudioPCI, and I use the ES1370 driver.

This was working fine in my previous config (zoot), and might be unrelated
to 
Pinstripe, however, I saw the problem during the first boot since pinstripe
was
upgraded, so I suspect it is.

Comment 1 Alan Cox 2000-08-03 18:40:11 UTC
Please attach the exact error text and a copy of /proc/pci

Alan


Comment 2 Dave Peacock 2000-08-04 18:22:13 UTC
Hey Alan,

As discussed on IRC...

From dmesg :-

es1370: version v0.31 time 16:24:53 Jul 26 2000
es1370: io ports 0x1040-0x107f in use

(Repeated many times)

From "modprobe es1370" :-

/lib/modules/2.2.16-17/misc/es1370.o: init_module: Device or resource busy
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters
/lib/modules/2.2.16-17/misc/es1370.o: insmod
/lib/modules/2.2.16-17/misc/es1370.o failed
/lib/modules/2.2.16-17/misc/es1370.o: insmod es1370 failed

...which is what I see at boot time.

Output of "cat /proc/pci" :-

PCI devices found:
  Bus  0, device   0, function  0:
    Host bridge: Intel 440LX - 82443LX PAC Host (rev 3).
      Medium devsel.  Fast back-to-back capable.  Master Capable. 
Latency=32.        Prefetchable 32 bit memory at 0xf8000000 [0xf8000008].
  Bus  0, device   1, function  0:
    PCI bridge: Intel 440LX - 82443LX PAC AGP (rev 3).
      Medium devsel.  Fast back-to-back capable.  Master Capable.  Latency=64. 
Min Gnt=8.
  Bus  0, device   7, function  0:
    ISA bridge: Intel 82371AB PIIX4 ISA (rev 1).
      Medium devsel.  Fast back-to-back capable.  Master Capable.  No bursts.
  Bus  0, device   7, function  1:
    IDE interface: Intel 82371AB PIIX4 IDE (rev 1).
      Medium devsel.  Fast back-to-back capable.  Master Capable. 
Latency=64.        I/O at 0x1000 [0x1001].
  Bus  0, device   7, function  2:
    USB Controller: Intel 82371AB PIIX4 USB (rev 1).
      Medium devsel.  Fast back-to-back capable.  IRQ 11.  Master Capable. 
Latency=64.
      I/O at 0x1020 [0x1021].
  Bus  0, device   7, function  3:
    Bridge: Intel 82371AB PIIX4 ACPI (rev 1).
      Medium devsel.  Fast back-to-back capable.
  Bus  0, device  13, function  0:
    SCSI storage controller: NCR 53c825 (rev 19).
      Medium devsel.  IRQ 10.  Master Capable.  Latency=140.  Min Gnt=17.Max
Lat=64.
      I/O at 0x1400 [0x1401].
      Non-prefetchable 32 bit memory at 0xf4001000 [0xf4001000].
      Non-prefetchable 32 bit memory at 0xf4000000 [0xf4000000].
  Bus  0, device  15, function  0:
    Multimedia controller: Unknown vendor Unknown device (rev 1).
      Vendor id=1105. Device id=8300.
      Medium devsel.  IRQ 5.  Master Capable.  Latency=64.
      Non-prefetchable 32 bit memory at 0xf4100000 [0xf4100000].
  Bus  0, device  16, function  0:
    Multimedia audio controller: Ensoniq AudioPCI (rev 0).
      Slow devsel.  IRQ 11.  Master Capable.  Latency=96.  Min Gnt=12.Max
Lat=128.
      I/O at 0x1040 [0x1041].
  Bus  1, device   0, function  0:
    VGA compatible controller: NVidia/SGS Thomson Riva 128 (rev 16).
      Medium devsel.  Fast back-to-back capable.  IRQ 9.  Master Capable. 
Latency=64.  Min Gnt=3.Max Lat=1.
      Non-prefetchable 32 bit memory at 0xf5000000 [0xf5000000].
      Prefetchable 32 bit memory at 0xfc000000 [0xfc000008].


Hope this helps! :-)


Comment 3 Michael K. Johnson 2000-08-04 20:15:32 UTC
Could you try the kernel packages temporarily at
ftp://people.redhat.com/johnsonm/testkernels/
and see if they fix the problem?

Comment 4 Dave Peacock 2000-08-05 13:47:00 UTC
Excellent work guys, thank you very much.

This kernel provided fixes the problem. No errors, and it appears to work
fine.

Thanks to all involved!!!

Keep up the good work! :-)

Comment 5 Dave Peacock 2000-08-05 15:48:45 UTC
Ok, looks like it was a false good alarm. I rebooted and the same problem is
back. :-(

Comment 6 Michael K. Johnson 2000-08-07 16:31:40 UTC
Created attachment 2194 [details]
This patch has been added to our current source tree to fix this problem.


Note You need to log in before you can comment on or make changes to this bug.