Bug 152135 - RFE: make Release Notes dialog resizable and/or maximized
Summary: RFE: make Release Notes dialog resizable and/or maximized
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-25 06:39 UTC by Ricky Ng-Adam
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 15:20:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ricky Ng-Adam 2005-03-25 06:39:41 UTC
Description of problem:

I like to read the Release Notes during the rather long install.  However, the
size of the textbox showing the Release Notes is too small, doesn't occupy the
whole screen and I'm unable to resize the dialog.  There also seems to be some 
wasted space between the blue bar title of the dialog and the textbox itself.

Why not have it fullscreen on top of the install dialog with maybe the same
title dark blue bar as the main install windows with "Release Notes" layered on top?

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1.Install
2.Press Release Notes dialog
3.
  
Actual results:

textbox is too small

Expected results:

maximized dialog with larger textbox

Additional info:

Comment 1 Need Real Name 2005-04-11 12:37:46 UTC
Suggest change to "make Release Notes dialog resizable"

Comment 2 Ricky Ng-Adam 2005-11-26 02:04:04 UTC
Still not resizable / fullscreen in FC5t1.  The font used also looks terrible
(reminds me of poor Postscript output on-screen).

Comment 3 Chris Lumens 2005-11-29 15:06:18 UTC
David has fixed this up for test2 so that the release notes viewer is fullscreened.

Comment 4 Ricky Ng-Adam 2006-01-17 03:17:57 UTC
In test 2 it is fullscreened at the start of the install, but once the install
is going (and when it is most likely to be used) the window is only half the
screen and not resizable. Maybe this was intentional to let the user both read
the release notes and look at the install progress... However, IMHO the user
would probably prefer having it fullscreen (or again, resizable) so it is more
readable.

Also:

*The font display is also still bad looking.
*There is still wasted space between the blue title bar and the text box
*There doesn't seem to be any good reason for the presence of an horizontal
scrollbar!

Comment 5 David Cantrell 2006-01-17 15:20:36 UTC
All of what you have described was intentional for test 2.  I changed the size
of the release notes viewer window to make it fullscreen in all stages up to the
installing packages stage.  Why do I make the window smaller there?  Exactly for
the reason you described.  I wanted the user to see the progress bar still going
while they are reading the release notes rather than thinking they have paused
the installation.  Originally I thought about having it fullscreen, but letting
the user still see the progress bar is better IMHO.

The window manager used during anaconda is not as useful as one might think.  We
can't have resizeable windows, for instance.  You can move them around, but you
can't resize them.

Regarding the actual display of the text in the release notes.... we use a
GtkHtml widget of some sort.  The reason for this is we prefer to open the HTML
version of the release notes.  If we don't find those, we default to opening the
text version.  Failing that, we just say we can't find the release notes.  If we
open the text version, we wrap it in HTML pre tags and slap that in the HTML
window.  The scrollbar is automatic based on the text you feed the widget. 
That's why it looks bad.  Final releases of Fedora Core usually come with HTML
versions of the release notes.


Note You need to log in before you can comment on or make changes to this bug.