Bug 152139 - Use evince as the default PDF viewer
Summary: Use evince as the default PDF viewer
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: shared-mime-info   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-03-25 10:02 UTC by Ingo Molnar
Modified: 2013-03-06 03:43 UTC (History)
4 users (show)

Fixed In Version: 0.16-2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-03 20:54:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ingo Molnar 2005-03-25 10:02:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1

Description of problem:
we should use evince as the default PDF viewer, not xpdf.

Version-Release number of selected component (if applicable):
firefox-1.0.2-1

How reproducible:
Always

Steps to Reproduce:
  

Additional info:

Comment 1 Warren Togami 2005-03-25 10:06:19 UTC
This isn't the responsibility of firefox I think.  It must be set somewhere in
GNOME's MIME system.  I don't know which package.  desktop team would know. 
Setting FC4Blocker.

Comment 2 David Zeuthen 2005-04-03 19:36:53 UTC
It's not immediately obvious to me that this can be fixed in shared-mime-info -
Jonathan, do you know?


Comment 3 David Zeuthen 2005-04-03 19:48:15 UTC
OK, presumably this patch

Index: defaults.list
===================================================================
RCS file: /cvs/dist/rpms/shared-mime-info/devel/defaults.list,v
retrieving revision 1.6
diff -u -r1.6 defaults.list
--- defaults.list       14 Oct 2004 19:59:37 -0000      1.6
+++ defaults.list       3 Apr 2005 19:44:45 -0000
@@ -60,8 +60,8 @@
 audio/x-mpeg=realplay.desktop
 audio/x-flac=rhythmbox.desktop
 audio/x-wav=rhythmbox.desktop
-application/pdf=gnome-ggv.desktop
-application/postscript=gnome-ggv.desktop
+application/pdf=evince.desktop
+application/postscript=evince.desktop
 application/x-gzpostscript=gnome-ggv.desktop
 image/x-eps=gnome-ggv.desktop
 application/x-qw=gnome-gnucash.desktop

should do the fix. 

It seems that Evince, per it's desktop file, doesn't handle the
application/x-gzpostscript MIME type. Is that correct, jrb? If Evince doesn't,
should we just drop that entry in defaults.lst? 

Another issue is that we need to have Evince in the default install for this to
work; is that the case now?

Comment 4 David Zeuthen 2005-04-03 20:54:27 UTC
Bah, ggv was removed from the distro on 2005-02-24 but defaults.list wasn't
updated :-/. I checked comps.xml and Evince is indeed installed per default.


Note You need to log in before you can comment on or make changes to this bug.